Bug 245386 - undefined symbol KLineEdit::mouseReleaseEvent(QMouseEvent*)
Summary: undefined symbol KLineEdit::mouseReleaseEvent(QMouseEvent*)
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: amarok   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Aurelien Bompard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-22 19:11 UTC by K H
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 1.4.6-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-09 15:53:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description K H 2007-06-22 19:11:44 UTC
Description of problem:
I updated amarok-1.4.6-1.fc7.i386.rpm from updates-testing.  Running amarok
results in the following undefined symbol.

$ amarok
Amarok: [Loader] Starting amarokapp..
Amarok: [Loader] Don't run gdb, valgrind, etc. against this binary! Use amarokapp.
amarokapp: symbol lookup error: /usr/lib/libamarok.so.0: undefined symbol:
_ZN9KLineEdit17mouseReleaseEventEP11QMouseEvent

This symbol is KLineEdit::mouseReleaseEvent(QMouseEvent*)

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. yum --enablerepo-updates-testing update amarok
2. amarok

The yum update pulled in NO kde dependencies
  
Actual results:
see above

Expected results:
I would hope that it would run.

Additional info:

Comment 1 Aurelien Bompard 2007-06-23 07:21:30 UTC
What is the version of kdelibs installed (rpm -q kdelibs) ? There's a new
version of KDE packages in testing, the bug may come from that.

Comment 2 K H 2007-06-23 14:19:24 UTC
kdelibs-3.5.6-9.fc7

Shouldn't the rpm have a dependency on the newer kdelibs such that it would
force an update of kdelibs also?

Comment 3 Julian Sikorski 2007-06-26 21:56:09 UTC
Updating kdelibs solves the problem. Ignore my comment in bodhi.

Comment 4 Aurelien Bompard 2007-06-27 05:55:34 UTC
(In reply to comment #2)
> Shouldn't the rpm have a dependency on the newer kdelibs such that it would
> force an update of kdelibs also?

True, I'll add this.
Thanks for your feedback

Comment 5 Fedora Update System 2007-06-28 01:46:49 UTC
amarok-1.4.6-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2007-07-09 15:53:12 UTC
amarok-1.4.6-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.