Bug 245405 - Bad SONAME Provides
Bad SONAME Provides
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: atlas (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Quentin Spencer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-22 17:03 EDT by Michael Schwendt
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-22 17:59:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2007-06-22 17:03:17 EDT
atlas provides liblapack.so.3
atlas-3dnow provides liblapack.so.3
atlas-sse provides liblapack.so.3
atlas-sse2 provides liblapack.so.3
lapack provides liblapack.so.3
  required by: lapack-devel - 3.1.1-1.fc7.i386
  required by: numpy - 1.0.3-0.1.fc7.i386
  required by: cernlib - 2006-15.fc7.i386
  required by: paw - 2006-15.fc7.i386
  required by: Macaulay2 - 0.9.95-4.fc7.i386
  required by: R-RScaLAPACK - 0.5.1-9.fc7.i386
  required by: atlas - 3.6.0-11.fc6.i386
  required by: atlas-3dnow - 3.6.0-11.fc6.i386
  required by: atlas-3dnow-devel - 3.6.0-11.fc6.i386
  required by: atlas-devel - 3.6.0-11.fc6.i386
  required by: atlas-sse - 3.6.0-11.fc6.i386
  required by: atlas-sse-devel - 3.6.0-11.fc6.i386
  required by: atlas-sse2 - 3.6.0-11.fc6.i386
  required by: atlas-sse2-devel - 3.6.0-11.fc6.i386
  required by: grass-libs - 6.2.1-16.fc7.i386
  required by: harminv - 1.3.1-8.fc6.i386
  required by: itpp - 3.10.10-1.fc7.i386
  required by: octave - 6:2.9.9-2.fc7.i386
  required by: octave-forge - 2006.07.09-9.fc7.i386
  required by: scipy - 0.5.2-2.2.fc7.i386

Indeed:

$ rpmls -p atlas-3.6.0-11.fc6.i386.rpm | grep libla
lrwxrwxrwx  /usr/lib/atlas/liblapack.so.3
-rwxr-xr-x  /usr/lib/atlas/liblapack.so.3.0
lrwxrwxrwx  /usr/lib/atlas/liblapack_atlas.so.3
-rwxr-xr-x  /usr/lib/atlas/liblapack_atlas.so.3.0

$ rpmls -p lapack-3.1.0-4.fc7.i386.rpm |grep libla
lrwxrwxrwx  /usr/lib/liblapack.so.3
lrwxrwxrwx  /usr/lib/liblapack.so.3.1
-rwxr-xr-x  /usr/lib/liblapack.so.3.1.0

The "atlas" packages must not provide the "liblapack.so.3" soname
as it conflicts with the lapack library.
Comment 1 Michael Schwendt 2007-06-22 17:05:37 EDT
Same for "libblas.so.3":

atlas provides libblas.so.3
atlas-3dnow provides libblas.so.3
atlas-sse provides libblas.so.3
atlas-sse2 provides libblas.so.3
blas provides libblas.so.3
  required by: blas-devel - 3.1.1-1.fc7.i386
  required by: lapack - 3.1.1-1.fc7.i386
  required by: numpy - 1.0.3-0.1.fc7.i386
  required by: R-RScaLAPACK - 0.5.1-9.fc7.i386
  required by: atlas - 3.6.0-11.fc6.i386
  required by: atlas-3dnow - 3.6.0-11.fc6.i386
  required by: atlas-3dnow-devel - 3.6.0-11.fc6.i386
  required by: atlas-devel - 3.6.0-11.fc6.i386
  required by: atlas-sse - 3.6.0-11.fc6.i386
  required by: atlas-sse-devel - 3.6.0-11.fc6.i386
  required by: atlas-sse2 - 3.6.0-11.fc6.i386
  required by: atlas-sse2-devel - 3.6.0-11.fc6.i386
  required by: grass-libs - 6.2.1-16.fc7.i386
  required by: itpp - 3.10.10-1.fc7.i386
  required by: octave - 6:2.9.9-2.fc7.i386
  required by: octave-forge - 2006.07.09-9.fc7.i386
  required by: scalapack - 1.7.5-1.fc7.i386
  required by: scipy - 0.5.2-2.2.fc7.i386
  required by: ufsparse - 2.1.1-1.fc6.i386
Comment 2 Quentin Spencer 2007-06-22 17:20:22 EDT
This was by design. The atlas package provides optimized binary compatible blas
and lapack libs. This scheme was modeled on the debian atlas package, which does
the same thing. What do you suggest I do?
Comment 3 Michael Schwendt 2007-06-22 17:59:59 EDT
Okay, I see the /etc/ld.so.conf.d/ file, so treat this one
as a false positive.

Note You need to log in before you can comment on or make changes to this bug.