Bug 245533 - Translation files exist, but are not being used
Summary: Translation files exist, but are not being used
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: util-linux   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
: ---
Assignee: Karel Zak
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: i18n
: 249134 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-25 07:58 UTC by Karel Zak
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version: RHBA-2007-0561
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 16:37:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0561 normal SHIPPED_LIVE util-linux bug fix update 2007-10-30 15:11:47 UTC

Description Karel Zak 2007-06-25 07:58:04 UTC
+++ This bug was initially created as a clone of Bug #243930 +++

Description of problem:

Applications of the util-linux package are looking for their translated messages
in a completely wrong location.

Version-Release number of selected component (if applicable):

Any version of util-linux in at least FC5, FC6 or F7.

How reproducible:

Every time.

Steps to Reproduce:
1. Set your locale to e.g. fi_FI.UTF-8, or any other language to which
util-linux has been translated.
2. Run e.g. `hwclock --help' or `fdisk --help'
  
Actual results:
The help text is shown in English.

Expected results:
Seeing the help text in Finnish (or whatever was chosen as language above).

Additional info:

The translation files exist in the util-linux RPM, and they also contain the
appropriate messages, but for some reason the applications are searching the
files in the wrong path.

Debugging the situation with `strace' reveals:
# strace hwclock --help 2>&1 | grep LC_MESSAGES
open("/share/locale/fi_FI.UTF-8/LC_MESSAGES/util-linux.mo", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/share/locale/fi_FI.utf8/LC_MESSAGES/util-linux.mo", O_RDONLY) = -1 ENOENT
(No such file or directory)
open("/share/locale/fi_FI/LC_MESSAGES/util-linux.mo", O_RDONLY) = -1 ENOENT (No
such file or directory)
open("/share/locale/fi.UTF-8/LC_MESSAGES/util-linux.mo", O_RDONLY) = -1 ENOENT
(No such file or directory)
open("/share/locale/fi.utf8/LC_MESSAGES/util-linux.mo", O_RDONLY) = -1 ENOENT
(No such file or directory)
open("/share/locale/fi/LC_MESSAGES/util-linux.mo", O_RDONLY) = -1 ENOENT (No
such file or directory)

Notice the path is /share, not /usr/share.

On FC6, the path begins e.g. with /root//fi_FI.UTF-8/..., and on FC5, an even
more surprising path /tmp//fi_FI.UTF-8/... is used.

-- Additional comment from kzak@redhat.com on 2007-06-12 17:41 EST --
This problem has been fixed in upstream code. I'll backport it to FC6 and FC7.
Thanks.

Comment 2 RHEL Product and Program Management 2007-06-25 08:06:26 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 7 Karel Zak 2007-08-02 10:56:45 UTC
*** Bug 249134 has been marked as a duplicate of this bug. ***

Comment 8 errata-xmlrpc 2007-11-07 16:37:22 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0561.html



Note You need to log in before you can comment on or make changes to this bug.