Bug 245582 - [RHEL4]: Add xenoprof support to the i386 and x86_64 PV kernels
Summary: [RHEL4]: Add xenoprof support to the i386 and x86_64 PV kernels
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.5
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Chris Lalancette
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-25 15:28 UTC by Chris Lalancette
Modified: 2007-11-17 01:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-29 14:30:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Very rough first patch for xenoprof support (30.97 KB, patch)
2007-07-25 18:27 UTC, Chris Lalancette
no flags Details | Diff

Description Chris Lalancette 2007-06-25 15:28:57 UTC
Description of problem:
We really should have support for Xenoprof in the RHEL-4 PV kernels.  I have a
preliminary patch, but it needs much review and testing since it touches some
core oprofile code.

Comment 1 Chris Lalancette 2007-07-25 18:27:07 UTC
Created attachment 159969 [details]
Very rough first patch for xenoprof support

This is my rough draft for xenoprof support for RHEL-4 PV.  It's been compile
and boot tested, but *not* tested to work for xenoprof yet.  It also contains
some changes to core oprofile code, so I need to go through that with a
fine-toothed comb and make sure things aren't being broken.  All in all,
definitely not ready yet, but a work in progress.

Chris Lalancette

Comment 2 Chris Lalancette 2007-10-29 14:30:10 UTC
Closing this out until somebody actually asks for this feature.

Chris Lalancette


Note You need to log in before you can comment on or make changes to this bug.