Bug 245596 - 'df: no file systems processed ' message on login
Summary: 'df: no file systems processed ' message on login
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
(Show other bugs)
Version: 7
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-25 16:54 UTC by Dave Fehling
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-28 16:50:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Requested output (8.02 KB, text/plain)
2007-06-27 17:40 UTC, Dave Fehling
no flags Details

Description Dave Fehling 2007-06-25 16:54:00 UTC
Description of problem:
Whenever a console is opened or a user is changed in console (ie su -) this
message appears before the prompt:

df: no file systems processed

Version-Release number of selected component (if applicable):

coreutils-6.9-2.fc7

How reproducible:



Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Here is someone else with the same problem:
http://www.linuxquestions.org/questions/showthread.php?t=558869

Comment 1 Tim Waugh 2007-06-26 12:47:40 UTC
I don't see this here.  The other reporter was using 'konsole', I notice -- are
you also using KDE?

Comment 2 Dave Fehling 2007-06-26 15:13:48 UTC
No, I am not using KDE, but it does also happen when I open a konsole from my
console.

Comment 3 Dave Fehling 2007-06-27 15:33:48 UTC
I also noticed that the comment appears after I type something like "less a.txt". 

Comment 4 Tim Waugh 2007-06-27 15:56:07 UTC
What does 'echo $PROMPT_COMMAND' say?

Comment 5 Dave Fehling 2007-06-27 16:50:10 UTC
PROMPT_COMMAND: Undefined variable.


Comment 6 Tim Waugh 2007-06-27 17:07:24 UTC
Please show me the output of this command:

strace -eopen bash -l


Comment 7 Dave Fehling 2007-06-27 17:40:46 UTC
Created attachment 158032 [details]
Requested output

Log is attached.

Comment 8 Tim Waugh 2007-06-28 15:12:00 UTC
What does 'rpm -qf /etc/profile.d/z_krb5.sh' say?

Comment 9 Dave Fehling 2007-06-28 16:48:26 UTC
krb5-workstation-fermi-1.8d-1.LTS4

Comment 10 Tim Waugh 2007-06-28 16:50:43 UTC
(Not one of our packages..)

Comment 11 Dave Fehling 2007-06-28 16:57:53 UTC
I apologize, here is the contents of the z_krb5.csh file.

Everything was previously uncommented. The first commented line was what was
causing the problem. I'm sorry for taking up your time, but I had no clue how
this file was being loaded and did not know that it was not being caused by one
of your files.

Thank you for your help.

set path = ( /usr/krb5/bin $path )
if ( `id -u` == 0 ) then
	set path = ( /usr/krb5/sbin $path )
endif
#df --type=afs | grep -qi afs
#
#if ( $? == 0 ) then
#/usr/krb5/bin/klist -s > & /dev/null
#if ( $? == 0 ) then
#	aklog -setpag
#endif
#endif



Note You need to log in before you can comment on or make changes to this bug.