Bug 245637 - [RHEL5.1][BUG][XEN] Guest OS hangs on IPF montecito
Summary: [RHEL5.1][BUG][XEN] Guest OS hangs on IPF montecito
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen   
(Show other bugs)
Version: 5.0
Hardware: ia64
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: Keiichiro Tokunaga
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords: OtherQA
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-25 20:10 UTC by Chris Lalancette
Modified: 2018-10-19 19:58 UTC (History)
7 users (show)

Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 19:54:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0959 normal SHIPPED_LIVE Updated kernel packages for Red Hat Enterprise Linux 5 Update 1 2007-11-08 00:47:37 UTC

Description Chris Lalancette 2007-06-25 20:10:09 UTC
From Fujitsu:

Description of problem:
Guest OS hangs on IPF montecito

How reproducible:
2h stress test like kernel compile and Guest OS hangs.
because of incorrect speclative VHPT walk(TLB related).

Steps to Reproduce:
2h stres test
Guest OS hangs.

Actual results:
Guest OS hangs.

Expected results:
Guest OS works fine.

Additional info:
With applying following patches, it fixes.

xen-ia64-unstable 15047
[IA64] Handle speculative vhpt walk
http://xenbits.xensource.com/ext/xen-ia64-unstable.hg?rev/31be207e005e

xen-ia64-unstable 15010
[IA64] Always insert entry to VHPT's head, or double TLB miss
occurs.
http://xenbits.xensource.com/ext/xen-ia64-unstable.hg?rev/8924215a5f95

Comment 6 Larry Troan 2007-07-09 12:18:30 UTC
On Tue, 2007-06-26 at 15:20 -0400, Peter Martuccelli wrote:
>From Don's patch tracking file the following list of items have been
> moved out to R5.2.  
> 
> Moved out to R5.2:
> ==================
<edited>
> 245637: [RHEL5.1][BUG][XEN] Guest OS hangs on IPF montetito

Comment 7 Martin Jenner 2007-07-09 15:30:50 UTC
QE ack for RHEL 5.1

Comment 8 Don Zickus 2007-07-10 16:21:03 UTC
in 2.6.18-33.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5

Comment 9 Larry Troan 2007-07-11 13:57:27 UTC
QE ACK per comment #7 assumes Fujitsu will test.

Comment 11 Red Hat Bugzilla 2007-07-25 00:52:30 UTC
change QA contact

Comment 12 John Poelstra 2007-08-24 05:23:01 UTC
A fix for this issue should have been included in the packages contained in the
most recent snapshot (partners.redhat.com) for RHEL5.1.  

Requested action: Please verify that your issue is fixed as soon as possible to
ensure that it is included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

More assistance: If you cannot access bugzilla, please reply with a message to
Issue Tracker and I will change the status for you.  If you need assistance
accessing ftp://partners.redhat.com, please contact your Partner Manager.

Comment 14 errata-xmlrpc 2007-11-07 19:54:21 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html



Note You need to log in before you can comment on or make changes to this bug.