Bug 245659 - yum Unable to read version lock configuration: [Errno 5] OSError: [Errno 2] No such file or directory: '/etc/yum/pluginconf.d/versionlock.list'
yum Unable to read version lock configuration: [Errno 5] OSError: [Errno 2] ...
Status: CLOSED DUPLICATE of bug 245658
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
5
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-25 18:18 EDT by david
Modified: 2014-01-21 17:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-27 02:54:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description david 2007-06-25 18:18:38 EDT
first let explain i am new to linux and bugzilla and NO IDEA WHAT SO EVER how 
to report this correctly.

I FOUND FIX HALF WAY THRU WRIGHTING THIS REPORT
FIX LISTED @ BOTTOM

Description of problem:
I installed ALL avial. yum components on 3 dif machines ( all the same OS) with 
Add/Remove Packages (checked anything that said yum* -about 6-8 things i think)
now when I reopen Addd/Remove Packages or kyum or yumex i get an error


Component: Software Manager
Summary: TBfef41469 versionlock.py:45:exclude_hook:PluginYumExit: Unable to 
read version lock configuration: [Errno 5] OSError: [Errno 2] No such file or 
directory: '/etc/yum/pluginconf.d/versionlock.list'

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 390, in ?
    main()
  File "/usr/sbin/pirut", line 386, in main
    pm.run()
  File "/usr/sbin/pirut", line 299, in run
    self.doRefresh()
  File "/usr/sbin/pirut", line 310, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 154, in 
reposSetup
    self.doSackSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 299, in 
doSackSetup
    self.plugins.run('exclude')
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 164, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/versionlock.py", line 45, in exclude_hook
    raise PluginYumExit('Unable to read version lock configuration: %s' % e)
PluginYumExit: Unable to read version lock configuration: [Errno 5] OSError: 
[Errno 2] No such file or directory: '/etc/yum/pluginconf.d/versionlock.list'

Local variables in innermost frame:
conduit: <yum.plugins.MainPluginConduit instance at 0xb320340c>
e: [Errno 5] OSError: [Errno 2] No such file or directory: '/etc/yum/
pluginconf.d/versionlock.list'
locklist: []
location: /etc/yum/pluginconf.d/versionlock.list

^^^^This error was produced by Add/Remove Packages ^^^

yumex is saying "error in loading repository data"
and here is a copy of the out put

Mirrordetection : default
Yum Version : 2.6.1 (/usr/share/yum-cli)
Loading "fedorakmod" plugin
Loading "protectbase" plugin
Loading "versionlock" plugin
Loading "installonlyn" plugin
Loading "kernel-module" plugin
0 packages excluded due to repository protections
Reading version lock configuration

I did not get a chance to install Kyum on this computer so the kyum report will 
come from a differant one with an older kernel

same problem


Version-Release number of selected component (if applicable):


How reproducible:
open any yum type app

Steps to Reproduce:
1.
2.
3.
  
Actual results:
it does not work

Expected results:
list of avail apps

Additional info:

!!!!!!!!!!!!!!
Talking with my brother on skype we just solved it!!!
and he think is related to yum-utils and yum-utils-plugins
http://lists.centos.org/pipermail/centos-devel/2005-November/000947.html
 versionlock -Allow locking packages to certain versions
http://wiki.linux.duke.edu/YumPlugins


!OK HOW TO FIX!
[17:07:26] kynalohikaarme: /etc/yum/pluginconf.d/versionlock.conf
[17:07:35] … set enable = 0
[17:07:44] … SOLVED!!!
Comment 1 Tim Lauridsen 2007-06-27 02:54:37 EDT

*** This bug has been marked as a duplicate of 245658 ***

Note You need to log in before you can comment on or make changes to this bug.