Bug 245677 - ipmitool-1.8.8-disabled-sensor patch breaks temp readings on Dell SC1435s
ipmitool-1.8.8-disabled-sensor patch breaks temp readings on Dell SC1435s
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: OpenIPMI (Show other bugs)
4.5
All Linux
low Severity medium
: ---
: ---
Assigned To: Jan Safranek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-25 21:56 EDT by Gavin Carr
Modified: 2009-05-18 16:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:09:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample patch correcting the problem (661 bytes, patch)
2007-06-25 21:56 EDT, Gavin Carr
no flags Details | Diff

  None (edit)
Description Gavin Carr 2007-06-25 21:56:36 EDT
Description of problem:

Moving to RHEL4 Update 5 breaks OpenIPMI temperature readings on (at least) Dell
SC1435 servers. The problem appears to be located in the
ipmitool-1.8.8-disabled-sensor.patch, as reverting that patch corrects the
problem. Note that the SC1435s are AMD-based servers, so are not affected by the
Woodcrest issues that seem to be behind that patch.

The same behaviour is also evident on RHEL5, apparently due to the same patch.

James Pearson supplied the attached patch which undoes the portion of the
disabled-sensor patch that seems to cause the problem (with the disclaimer that
he wasn't an OpenIPMI expert). I can report that James' patch fixes the problem
for me on both RHEL4U5 and RHEL5.


Version-Release number of selected component (if applicable):

1.4.14-1.4E.17

How reproducible:

  # ipmitool sdr type Temperature
  Temp             | 01h | ns  |  3.1 | Disabled
  Planar Temp      | 04h | ok  |  7.1 | 30 degrees C

Reverting that patch:

  # ipmitool sdr type Temperature
  Temp             | 01h | ok  |  3.1 | 35 degrees C
  Planar Temp      | 04h | ok  |  7.1 | 30 degrees C



Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Gavin Carr 2007-06-25 21:56:36 EDT
Created attachment 157844 [details]
Sample patch correcting the problem
Comment 2 Phil Knirsch 2008-04-18 06:27:47 EDT
Reviewed patch, looks good. Proposing for RHEL-4.8 and granting Devel ACK.

Read ya, Phil
Comment 3 RHEL Product and Program Management 2008-09-05 13:05:26 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Jan Safranek 2008-10-23 10:49:09 EDT
fixed by rebase to ipmitool-1.8.10, bug #454833.
Comment 11 errata-xmlrpc 2009-05-18 16:09:06 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0964.html

Note You need to log in before you can comment on or make changes to this bug.