Bug 245692 - package-cleanup gets traceback
Summary: package-cleanup gets traceback
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-utils   
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-26 03:23 UTC by Michal Jaegermann
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 17:49:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2007-06-26 03:23:35 UTC
Description of problem:

I tried to use 'package-cleanup --oldkernels' when I actually
had old kernels installed.  These were FC5 kernels which got stuck
due to a bug 245691.  The result was the following traceback:

/usr/bin/package-cleanup:312: DeprecationWarning: returnHeaderByTuple() will go
away in a future version of Yum.

  hdr = my.rpmdb.returnHeaderByTuple(kernel)[0]
Traceback (most recent call last):
  File "/usr/bin/package-cleanup", line 402, in <module>
    main()
  File "/usr/bin/package-cleanup", line 371, in main
    removeKernels(my, opts.kernelcount, opts.confirmed, opts.keepdevel)
  File "/usr/bin/package-cleanup", line 317, in removeKernels
    my.populateTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 221, in populateTs
    self.ts.addErase(txmbr.po.idx)
  File "/usr/lib/python2.5/site-packages/yum/packages.py", line 707, in __getattr__
    return self.hdr[thing]
KeyError: 'unknown header tag'

This is only a minor hiccup as cleaning up old kernels is easy in
any case, but ...  Once these kernels were gone the same command
just returned with "No kernel related packages to remove".  Not
that big surprise.

Version-Release number of selected component (if applicable):
yum-utils-1.1.5-1.fc7

Comment 1 seth vidal 2007-11-21 17:49:57 UTC
this is fixed in upstream now. thanks.


Note You need to log in before you can comment on or make changes to this bug.