Bug 245753 - can't get pattern (...) address: Name or service not known
can't get pattern (...) address: Name or service not known
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tcp_wrappers (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Tomas Janousek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 220015
  Show dependency treegraph
 
Reported: 2007-06-26 10:14 EDT by H.J. Lu
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 7.6-48.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-12 19:37:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description H.J. Lu 2007-06-26 10:14:42 EDT
I have

[root@gnu-2 log]# cat /etc/hosts.allow
#
# hosts.allow   This file describes the names of the hosts which are
#               allowed to use the local INET services, as decided
#               by the '/usr/sbin/tcpd' server.
#
ALL: gnu-*.sc.intel.com
ALL: gnu.sc.intel.com
cvspserver: *
cvs: *
svn: *
sshd: *
[root@gnu-2 log]#

I am getting

Jun 26 07:07:24 gnu-2 sshd[27139]: warning: /etc/hosts.allow, line 6: can't get
pattern (gnu-*.sc.intel.com) address: Name or service not known
Jun 26 07:07:24 gnu-2 sshd[27139]: warning: /etc/hosts.allow, line 6: can't get
pattern (gnu-*.sc.intel.com) address: Name or service not known
Jun 26 07:07:24 gnu-2 sshd[27139]: warning: /etc/hosts.allow, line 7: can't get
pattern (gnu.sc.intel.com) address: Name or service not known

I didn't get those on FC6 with the same /etc/hosts.allow.
Comment 1 H.J. Lu 2007-06-26 11:40:41 EDT
I believe that fix for PR 220015, tcp_wrappers-7.6-220015.patch, is
the cause.
Comment 2 Tomas Janousek 2007-06-26 11:48:37 EDT
Yes, definitely. I'll fix it tomorrow.
Comment 3 Tomas Janousek 2007-06-29 08:12:09 EDT
Ok, thanks again for the report. I rewrote the patch for 220015 and a fixed
build is available in updates-testing as tcp_wrappers-7.6-48.
Comment 4 H.J. Lu 2007-06-29 09:42:13 EDT
tcp_wrappers-7.6-48 works for me.  Thanks.
Comment 5 Tomas Janousek 2007-06-29 09:48:31 EDT
Thx for your quick response. I will push the update to final once I get back
from vacation and the QA verifies that the new patch still fixes the bugs in
question.
Comment 6 Fedora Update System 2007-06-29 10:02:49 EDT
tcp_wrappers-7.6-48.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2007-07-12 19:37:46 EDT
tcp_wrappers-7.6-48.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.