This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 245772 - [PATCH]Middle mouse button of some models not working with kernel 2.6.20
[PATCH]Middle mouse button of some models not working with kernel 2.6.20
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-26 13:07 EDT by Simone Gotti
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 2.6.22.7-57.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-26 16:36:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 8099 None None None Never

  None (edit)
Description Simone Gotti 2007-06-26 13:07:53 EDT
Description of problem:

In one of my usb mice the middle mouse button doesn't work with the Fedora Core
6 2.6.20 kernels.
After some searches I found that, to solve problems with some mouse models, a
bug was introduced in 2.6.20:

http://bugzilla.kernel.org/show_bug.cgi?id=8099

Looks like in vanilla the patch was applied in 2.6.21.
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=25914662b7e86f8cf8abdde0497e7fe8bdddf2ae

I tested the patch provided in the bug report on the 2.6.20-1.2962.fc6 kernel
and a reworked git patch (to make it apply on 2.6.20-1.2962.fc6) and both worked
well at least for me.


Thanks!
Bye!



Version-Release number of selected component (if applicable):

kernel-2.6.20-X.YYYY.fc6

How reproducible:

Always.

Note You need to log in before you can comment on or make changes to this bug.