This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 245789 - RHEL5 install fails with 'module' object has no attribute 'HTTPSHandler'
RHEL5 install fails with 'module' object has no attribute 'HTTPSHandler'
Status: CLOSED DUPLICATE of bug 245734
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
ia64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-26 14:07 EDT by Prarit Bhargava
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-26 14:08:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Prarit Bhargava 2007-06-26 14:07:12 EDT
Description of problem:

All ia64 installs are failing with the error:

Running anaconda, the Red Hat Enterprise Linux Server system installer - please
wait...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 614, in ?
    instClass = getInstClass(opts)
  File "/usr/bin/anaconda", line 352, in getInstClass
    from kickstart import Kickstart
  File "/usr/lib/anaconda/kickstart.py", line 27, in ?
    import urlgrabber.grabber as grabber
  File "/usr/lib/python2.4/site-packages/urlgrabber/__init__.py", line 53, in ?
    from grabber import urlgrab, urlopen, urlread
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 406, in ?
    import keepalive
  File "/usr/lib/python2.4/site-packages/urlgrabber/keepalive.py", line 339, in ?
    class HTTPSHandler(KeepAliveHandler, urllib2.HTTPSHandler):
AttributeError: 'module' object has no attribute 'HTTPSHandler'
install exited abnormally [1/1] 
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /mnt/runtime done
        disabling /dev/loop0
        /proc done
        /dev/pts done
        /sys done
        /tmp/ramfs done
        /mnt/source done
        /selinux done
you may safely reboot your system

Version-Release number of selected component (if applicable):
RHEL5-Server-20070626.nightly


How reproducible: 100%


Steps to Reproduce:
1. Attempt to install via NFS
  
Actual results:  See above.


Expected results: Install should succeed.


Additional info: Seen on all HP systems and SGI boxes.
Comment 1 Prarit Bhargava 2007-06-26 14:08:13 EDT

*** This bug has been marked as a duplicate of 245734 ***

Note You need to log in before you can comment on or make changes to this bug.