Bug 245829 - hplip: hp-setup can no longer find PPD file for Color LaserJet 2840
hplip: hp-setup can no longer find PPD file for Color LaserJet 2840
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-26 17:47 EDT by Bernard Johnson
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 2.7.7-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-28 05:29:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ppd that worked (10.29 KB, application/octet-stream)
2007-06-28 14:47 EDT, Bernard Johnson
no flags Details

  None (edit)
Description Bernard Johnson 2007-06-26 17:47:49 EDT
Description of problem:
hp-setup can no longer find PPD file for HP Color LaserJet 2840.  This is a
regression since F-7:

# hp-setup -i 192.168.1.11

HP Linux Imaging and Printing System (ver. 1.7.4a)
Printer/Fax Setup Utility ver. 4.5

Copyright (c) 2001-7 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.


Setting up device: hp:/net/HP_Color_LaserJet_2840?ip=192.168.1.11

(Note: Defaults for each question are maked with a '*'. Press <enter> to accept
the default.)


PRINT QUEUE SETUP

Please enter a name for this print queue (m=use model
name:'HP_Color_LaserJet_2840'*, q=quit) ?
Using queue name: HP_Color_LaserJet_2840
error: Unable to find an appropriate PPD file.

Would you like to specify the path to the correct PPD file to use (y=yes, n=no*,
q=quit) ?

Furthermore, if I specify the path to the file, hplip then says "error: File not
found or not an appropriate (PPD) file.

If I copy the PPD file from F-7, to this devel machine and use that, I'm able to
 continue until the cups queue is being setup then I hit bug #186231.

Version-Release number of selected component (if applicable):
hplip-1.7.4a-2.fc8
foomatic-3.0.2-49.fc8
Comment 1 Tim Waugh 2007-06-28 06:58:43 EDT
Can you attach the PPD you were using on F-7 please?
Comment 2 Bernard Johnson 2007-06-28 14:47:07 EDT
Created attachment 158150 [details]
ppd that worked

Just to be clear here, bug #186231 existed before I tried to setup this
printer, it was not caused by the PPD that I pulled from F-7.
Comment 3 Tim Waugh 2007-08-09 08:56:24 EDT
Please run 'hp-setup -l debug -i 192.168.1.11', try to configure the queue
again, and show me the output.  Thanks.
Comment 4 Bernard Johnson 2007-08-27 15:04:46 EDT
This bug seems to no longer exist with hplip-2.7.7-1.fc8.

Note You need to log in before you can comment on or make changes to this bug.