Bug 245833 - taglib-config from i386 devel package overrides x86_64 version
Summary: taglib-config from i386 devel package overrides x86_64 version
Status: CLOSED DUPLICATE of bug 343241
Alias: None
Product: Fedora
Classification: Fedora
Component: taglib   
(Show other bugs)
Version: 7
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Aurelien Bompard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-26 22:38 UTC by Harry Bock
Modified: 2008-02-21 04:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-21 04:56:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Harry Bock 2007-06-26 22:38:11 UTC
Description of problem:
When installing taglib-devel on an AMD64 system, yum installs
both the x86_64 and i386 packages (understandably).  However,
taglib-config from the i386 package is (presumably) installed
over the same binary from the x86_64 package.  This causes
problems when building something from source (specifically,
kdelibs trunk) that needs to use taglib-config --libs, which
returns -L/usr/lib instead of the correct -L/usr/lib64, which
causes the link to fail.  

Version-Release number of selected component (if applicable):
1.4-5.fc7

How reproducible:
Install taglib-devel on an x86_64 build of FC7. You
must install both arch packages at the same time for
this to work (or fail, as the case may be ;) ).

Steps to Reproduce:
1. yum -y install taglib-devel
2. taglib-config --libs
3.
  
Actual results:
-L/usr/lib -ltag

Expected results:
-L/usr/lib64 -ltag

Additional info:
Removing both packages and installing only the x86_64 package
works. Trying to install the i386 version separately causes an
RPM error:

Transaction Check Error:
  file /usr/bin/taglib-config from install of taglib-devel-1.4-5.fc7 conflicts 
with file from package taglib-devel-1.4-5.fc7

Comment 1 Rex Dieter 2008-02-21 04:56:40 UTC
Fixed in rawhide.

* Wed Jan 16 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 1.5-0.7.20080116svn
- svn20080116 snapshot
- multiarch conflicts (#343241)

An update for f7 should be coming soon.

*** This bug has been marked as a duplicate of 343241 ***


Note You need to log in before you can comment on or make changes to this bug.