Bug 245921 - GFS2: BUG: soft lockup detected on CPU#1!
GFS2: BUG: soft lockup detected on CPU#1!
Status: CLOSED DUPLICATE of bug 245832
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs2-utils (Show other bugs)
5.1
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Steve Whitehouse
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-27 09:14 EDT by Mike
Modified: 2010-01-11 22:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-27 18:46:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike 2007-06-27 09:14:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

Description of problem:
When running a test script on a GFS2 filesystem (3 systems clustered), the box hangs with the following output going to console repeatedly.

Call Trace:
 <IRQ>  [<ffffffff800b2c85>] softlockup_tick+0xdb/0xed
 [<ffffffff800933d1>] update_process_times+0x42/0x68
 [<ffffffff80073d97>] smp_local_timer_interrupt+0x23/0x47
 [<ffffffff80074459>] smp_apic_timer_interrupt+0x41/0x47
 [<ffffffff8005bcc2>] apic_timer_interrupt+0x66/0x6c
 <EOI>  [<ffffffff800cd504>] cache_reap+0x0/0x219
 [<ffffffff8006270c>] .text.lock.spinlock+0x2/0x30
 [<ffffffff883d02e5>] :gfs2:gfs2_ail1_empty+0x1a/0x95
 [<ffffffff883c5211>] :gfs2:gfs2_logd+0x48/0x148
 [<ffffffff883c51c9>] :gfs2:gfs2_logd+0x0/0x148
 [<ffffffff8003216e>] kthread+0xfe/0x132
 [<ffffffff8005bfe5>] child_rip+0xa/0x11
 [<ffffffff8009b4a3>] keventd_create_kthread+0x0/0x61
 [<ffffffff80032070>] kthread+0x0/0x132
 [<ffffffff8005bfdb>] child_rip+0x0/0x11

BUG: soft lockup detected on CPU#1!


Script: 

my $i=0;
my $max=shift(@ARGV);
my $d=shift(@ARGV);
if (not defined $d) {
    $d="";
}
foreach(my $i=0;$i<$max;$i++) {
    my $filename=sprintf("%s-%d%s",rand()*100000,$i,$d);
    open FOO, ">$filename";
    for (my $j=0;$j<1500;++$j) {
        print FOO "This is fun!!\n";
    }
    close FOO;
}

Assuming a mount at /gfs

Queue up a good chunk of these - each working their own directory...

cd /gfs
mkdir foo1
cd foo1
perl -w ~/foo.pl 10000000 A &
cd ..
mkdir foo2
cd foo2
perl -w ~/foo.pl 10000000 A &
cd ..
mkdir foo3
cd foo3
perl -w ~/foo.pl 10000000 A &
cd ..
mkdir foo4
cd foo4
perl -w ~/foo.pl 10000000 A &
cd ..
mkdir foo5
cd foo5
perl -w ~/foo.pl 10000000 A &

Version-Release number of selected component (if applicable):
kernel-2.6.18-8.1.6.el5

How reproducible:
Always


Steps to Reproduce:
1. Setup a cluster with GFS2
2. Run the script above
3.

Actual Results:
The system hangs, with the dump displaying on console.

Expected Results:


Additional info:
Comment 1 Mike 2007-06-27 09:19:04 EDT
Forgot to mention we are on the latest cman package as well.
cman-2.0.64-1.el5
Comment 2 Steve Whitehouse 2007-06-27 09:30:36 EDT
I greatly suspect that this is a dup of bz #245832 since the spinlock would be a
common feature of the two routines.
Comment 3 Mike 2007-06-27 10:33:44 EDT
I'm unable to view bug #245832..."You are not autherized to access bug #245832".
 If that incident is being used to track this problem, can it be made public so
that I can subscribe/comment to it?
Comment 4 Steve Whitehouse 2007-06-27 18:46:05 EDT
I'll mark this as a dup so that you get added to the CC list of the other bug,
then you should be able to see it. Let me know if that doesn't work.

*** This bug has been marked as a duplicate of 245832 ***

Note You need to log in before you can comment on or make changes to this bug.