Bug 245990 - cman module didn't load on startup (latest patches installed)
cman module didn't load on startup (latest patches installed)
Status: CLOSED DUPLICATE of bug 244251
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: cman-kernel (Show other bugs)
4
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Feist
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-27 15:46 EDT by Szabolcs Horvath
Modified: 2009-04-16 16:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-28 09:09:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"rpm -qa" output (14.78 KB, text/plain)
2007-06-27 15:46 EDT, Szabolcs Horvath
no flags Details

  None (edit)
Description Szabolcs Horvath 2007-06-27 15:46:32 EDT
Description of problem:
We have a fresh new RHEL AS 4.5 + cluster suite installation with the latest
patches installed with up2date. I'm sending you the rpm -qa output as an
attachment. At boot time, the cman.ko kernel module didn't load, because cman
module is not found in the correct directory. 

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux AS release 4 (Nahant Update 5)
Cluster Suite latest (which can be downloaded from the web site)
cman-kernel-2.6.9-50.2
cman-kernel-smp-2.6.9-50.2

How reproducible:
Install a new RHEL AS 4.5 with the cluster suite + latest patches. cman service
won't start because they don't find the kernel module in the correct directory.

Actual results:
Jun 27 14:37:55 t-clu02a ccsd[13669]: Starting ccsd 1.0.10:
Jun 27 14:37:55 t-clu02a ccsd[13669]:  Built: Mar 19 2007 17:44:26
Jun 27 14:37:55 t-clu02a ccsd[13669]:  Copyright (C) Red Hat, Inc.  2004  All
rights reserved.
Jun 27 14:37:55 t-clu02a ccsd:  succeeded
Jun 27 14:38:01 t-clu02a cman: FATAL: Module cman not found. failed
Jun 27 14:38:24 t-clu02a ccsd[13669]: Unable to connect to cluster
infrastructure after 30 seconds.
Jun 27 14:38:54 t-clu02a ccsd[13669]: Unable to connect to cluster
infrastructure after 60 seconds.
Jun 27 14:39:24 t-clu02a ccsd[13669]: Unable to connect to cluster
infrastructure after 90 seconds.
Jun 27 14:39:54 t-clu02a ccsd[13669]: Unable to connect to cluster
infrastructure after 120 seconds.
Jun 27 14:40:24 t-clu02a ccsd[13669]: Unable to connect to cluster
infrastructure after 150 seconds.
Jun 27 14:40:54 t-clu02a ccsd[13669]: Unable to connect to cluster
infrastructure after 180 seconds.
Jun 27 14:41:24 t-clu02a ccsd[13669]: Unable to connect to cluster
infrastructure after 210 seconds.


Expected results:
cman service starts without errors.

Additional info:
I found that cman-kernel-smp package installs the following files:
drwxr-xr-x   2 root     root            0 Apr 24 18:03
./lib/modules/2.6.9-55.ELsmp/kernel/cluster
-rwxr-xr-x   1 root     root       159616 Apr 24 18:03
./lib/modules/2.6.9-55.ELsmp/kernel/cluster/cman.ko
-rwxr-xr-x   1 root     root       185592 Apr 24 18:03
./lib/modules/2.6.9-55.ELsmp/kernel/cluster/cman.symvers

Current kernel version:
Linux t-clu02a.xxxxx.hu 2.6.9-55.0.2.ELsmp #1 SMP Tue Jun 12 17:59:08 EDT 2007
i686 i686 i386 GNU/Linux

The kernel searches kernel module at /lib/modules/`uname -r`, but this directory
does not exists!

# ls -1
2.6.9-48.EL
2.6.9-48.ELsmp
2.6.9-55.0.2.EL
2.6.9-55.0.2.ELsmp
2.6.9-55.EL
2.6.9-55.ELhugemem
2.6.9-55.ELsmp
kabi-4.0-0
kabi-4.0-0smp

Workaround:
cp -r /lib/modules/2.6.9-55.ELsmp/kernel/cluster
/lib/modules/2.6.9-55.0.2.ELsmp/kernel/
Comment 1 Szabolcs Horvath 2007-06-27 15:46:32 EDT
Created attachment 158049 [details]
"rpm -qa" output
Comment 2 Szabolcs Horvath 2007-06-27 15:51:28 EDT
Hello,

I know "RHBA-2007:0135-3" bug fix advisory, but we have the latest patches
installed:

# rpm -qa | egrep "^cman-|^kernel" | sort
cman-1.0.17-0
cman-devel-1.0.17-0
cman-kernel-2.6.9-50.2
cman-kernel-hugemem-2.6.9-50.2
cman-kernel-smp-2.6.9-50.2
cman-kernheaders-2.6.9-50.2
kernel-2.6.9-48.EL
kernel-2.6.9-55.0.2.EL
kernel-devel-2.6.9-48.EL
kernel-devel-2.6.9-55.0.2.EL
kernel-smp-2.6.9-48.EL
kernel-smp-2.6.9-55.0.2.EL
kernel-smp-devel-2.6.9-55.0.2.EL
kernel-utils-2.4-13.1.99

Szabolcs
Comment 3 Nate Straz 2007-06-28 09:09:48 EDT

*** This bug has been marked as a duplicate of 244251 ***

Note You need to log in before you can comment on or make changes to this bug.