Bug 246017 - GFS2 soft lockup in gfs2_logd
Summary: GFS2 soft lockup in gfs2_logd
Status: CLOSED DUPLICATE of bug 245832
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Robert Peterson
QA Contact: Dean Jansa
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-27 21:10 UTC by Abhijith Das
Modified: 2009-05-28 03:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-27 22:39:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Abhijith Das 2007-06-27 21:10:28 UTC
Hit this soft lockup while running revolver on the smoke cluster. This is the
latest RHEL5 kernel from CVS with all the latest patches from rhkernel-list as
of this morning.

Looks like kool died and came up. This lockup is shortly after mount.

Description of problem:
Jun 27 14:40:09 kool qarshd[5915]: Running cmdline: cman_tool services 
Jun 27 14:40:09 kool xinetd[5551]: EXIT: qarsh status=0 pid=5915 duration=0(sec)
Jun 27 14:40:10 kool xinetd[5551]: START: qarsh pid=5918 from=10.15.89.55
Jun 27 14:40:10 kool qarshd[5918]: Talking to peer 10.15.89.55:56381
Jun 27 14:40:10 kool qarshd[5918]: Running cmdline: mount 
Jun 27 14:40:10 kool xinetd[5551]: EXIT: qarsh status=0 pid=5918 duration=0(sec)
Jun 27 14:41:07 kool kernel: BUG: soft lockup detected on CPU#1!
Jun 27 14:41:07 kool kernel: 
Jun 27 14:41:07 kool kernel: Call Trace:
Jun 27 14:41:07 kool kernel:  <IRQ>  [<ffffffff800b4f8b>] softlockup_tick+0xdb/0xed
Jun 27 14:41:07 kool kernel:  [<ffffffff800930fa>] update_process_times+0x42/0x68
Jun 27 14:41:07 kool kernel:  [<ffffffff800746f8>]
smp_local_timer_interrupt+0x23/0x47
Jun 27 14:41:07 kool kernel:  [<ffffffff80074dba>]
smp_apic_timer_interrupt+0x41/0x47
Jun 27 14:41:07 kool kernel:  [<ffffffff8005bc8e>] apic_timer_interrupt+0x66/0x6c
Jun 27 14:41:07 kool kernel:  <EOI>  [<ffffffff80062a18>] _spin_lock+0x3/0xa
Jun 27 14:41:07 kool kernel:  [<ffffffff8843b566>]
:gfs2:databuf_lo_before_commit+0x337/0x594
Jun 27 14:41:07 kool kernel:  [<ffffffff8009b291>] keventd_create_kthread+0x0/0x61
Jun 27 14:41:07 kool kernel:  [<ffffffff88439c78>] :gfs2:gfs2_log_flush+0x12b/0x2da
Jun 27 14:41:07 kool kernel:  [<ffffffff8842e29f>] :gfs2:gfs2_logd+0xa2/0x148
Jun 27 14:41:07 kool kernel:  [<ffffffff8842e1fd>] :gfs2:gfs2_logd+0x0/0x148
Jun 27 14:41:07 kool kernel:  [<ffffffff8003213e>] kthread+0xfe/0x132
Jun 27 14:41:07 kool kernel:  [<ffffffff8005bfb1>] child_rip+0xa/0x11
Jun 27 14:41:07 kool kernel:  [<ffffffff8009b291>] keventd_create_kthread+0x0/0x61
Jun 27 14:41:07 kool kernel:  [<ffffffff80032040>] kthread+0x0/0x132
Jun 27 14:41:07 kool kernel:  [<ffffffff8005bfa7>] child_rip+0x0/0x11
Jun 27 14:41:07 kool kernel:

Comment 1 Robert Peterson 2007-06-27 22:39:33 UTC
Same as bug #245823.  Closing as dup.


*** This bug has been marked as a duplicate of 245832 ***


Note You need to log in before you can comment on or make changes to this bug.