Bug 246026 - wrong fonts after libXfont update to libXfont-1.2.9-1.fc8
wrong fonts after libXfont update to libXfont-1.2.9-1.fc8
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libXfont (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-27 18:32 EDT by Patrice Dumas
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-28 09:41:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xset q > xset-q.out (928 bytes, text/plain)
2007-06-27 18:33 EDT, Patrice Dumas
no flags Details

  None (edit)
Description Patrice Dumas 2007-06-27 18:32:40 EDT
Description of problem:

The fonts in fluxbox window titles have changed.

And in gv, or xpdf (gv is an Xaw app, xpdf is lesstif based), I get:
Warning: Cannot convert string
"-*-Helvetica-Medium-R-Normal--*-140-*-*-P-*-ISO8859-1" to type FontStruct

Warning: Cannot convert string
"-*-times-medium-r-normal--14-*-*-*-*-*-iso8859-1" to type FontStruct

$ ls -l /etc/X11/fontpath.d
ls: cannot access /etc/X11/fontpath.d: No such file or directory

$ rpm -qa | grep xorg-x11-fonts
xorg-x11-fonts-misc-7.1-3.fc7
xorg-x11-fonts-ISO8859-1-100dpi-7.1-3.fc7
xorg-x11-fonts-base-7.1-3.fc7
xorg-x11-fonts-ISO8859-1-75dpi-7.1-3.fc7
xorg-x11-fonts-truetype-7.1-3.fc7
xorg-x11-fonts-75dpi-7.1-3.fc7
xorg-x11-fonts-100dpi-7.1-3.fc7
xorg-x11-fonts-Type1-7.1-3.fc7

$ xlsfonts
-misc-fixed-medium-r-semicondensed--0-0-75-75-c-0-iso8859-1
-misc-fixed-medium-r-semicondensed--13-100-100-100-c-60-iso8859-1
-misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso8859-1
6x13
cursor
fixed

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Patrice Dumas 2007-06-27 18:33:47 EDT
Created attachment 158072 [details]
xset q > xset-q.out
Comment 2 Kristian Høgsberg 2007-06-28 09:41:13 EDT
Ah, you need to update the fonts packages.  There was a one day window where
rawhide had the new libXfont package but didn't have the updated fonts packages
and it looks like you did 'yum update' at that time.  If you do a new yum
update, either wholesale or just for libXfont xorg-x11-fonts-*, you should get
your fonts back.
Comment 3 Patrice Dumas 2007-06-29 16:46:50 EDT
Indeed, it was that.

Shouldn't something be said about that in the packaging 
guidelines?
Comment 4 Kristian Høgsberg 2007-07-02 09:53:37 EDT
(In reply to comment #3)
> Indeed, it was that.
> 
> Shouldn't something be said about that in the packaging 
> guidelines?

I don't think we need the guidelines here... the problem was that I split the
update over two days and should probably put a Conflicts line in the X server
and xfs packages to force an update of the old fonts in case.
Comment 5 Patrice Dumas 2007-07-07 03:41:15 EDT
(In reply to comment #4)

> I don't think we need the guidelines here...

Isn't it necessary for font packagers to add something in
/etc/X11/fontpath.d/
In that case it should certainly be in the guidelines, (together
with better scriptlets, but I have already asked that repeatedly).

Note You need to log in before you can comment on or make changes to this bug.