Bug 246045 - missing dependency when upgrading from fc6 to f7 using yum
missing dependency when upgrading from fc6 to f7 using yum
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-27 21:49 EDT by Harold Pritchett
Modified: 2014-01-21 17:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-01 11:22:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of the yum command which fails (52.84 KB, text/plain)
2007-06-27 21:58 EDT, Harold Pritchett
no flags Details

  None (edit)
Description Harold Pritchett 2007-06-27 21:49:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.0.3705; .NET CLR 1.1.4322; Media Center PC 4.0; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30)

Description of problem:
Using yum to upgrade from fc6 to f7 following the directions found at:
http://fedoraproject.org/wiki/YumUpgradeFaq
  and at
http://www.ioncannon.net/linux/68/upgrading-from-fc6-to-fedora7-with-yum/

A clean install of fc6 was done from the dvd.  It was upgraded using yum -y update to the latest version. I then did "yum clean all".

I switched the yum repositories with:
rpm -Uhv http://download.fedora.redhat.com/pub/fedora/linux/releases/7/Fedora/x86_64/os/Fedora/fedora-release-7-3.noarch.rpm http://download.fedora.redhat.com/pub/fedora/linux/releases/7/Fedora/x86_64/os/Fedora/fedora-release-notes-7.0.0-1.noarch.rpm

The following three files were moved from the /etc/yum.repos.d directory and the equivalent .rpmnew files were renamed to .repo in the /etc/yum.repos.d directory:
fedora-development.repo
fedora-updates.repo
fedora-updates-testing.repo

I then did a "yum -y upgrade" and it failed with the following error (this is the last few lines of the output.  Then entire output from yum is in an attachment.

--> Running transaction check
--> Processing Dependency: python(abi) = 2.4 for package: libxml2-python
--> Finished Dependency Resolution
Error: Missing Dependency: python(abi) = 2.4 is needed by package libxml2-python
# 

research on the web indicates that the python package should be providing the dependencies for python(abi) but yum doesn't seem to see it.



Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.run "yum -y upgrade"


Actual Results:
see attachment

Expected Results:
It should have downloaded and installed the files for F7

Additional info:
Computer is aged dual processor Pentium II (Deschutes) machine.  Four 10Gb disk drives configured in a raid5 array with one spare.
Comment 1 Harold Pritchett 2007-06-27 21:58:45 EDT
Created attachment 158088 [details]
Output of the yum command which fails
Comment 2 Jeremy Katz 2007-06-28 10:58:13 EDT
Did you have the updates repo enabled?  You have the FC6 libxml2 update
installed which is newer than the original F7 libxml2 package.  
Comment 3 Harold Pritchett 2007-06-28 11:35:55 EDT
Short answer:  Yes I did have the updates repo enabled?

Here is the contents of my /etc/yum.repo.d/fedora-updates-repo file:

# more fedora-updates-repo
[updates]
name=Fedora $releasever - $basearch - Updates
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/updates/$releasever
/$basearch/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-f$
releasever&arch=$basearch
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora

[updates-debuginfo]
name=Fedora $releasever - $basearch - Updates - Debug
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/updates/$releasever
/$basearch/debug/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-de
bug-f$releasever&arch=$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora

[updates-source]
name=Fedora $releasever - Updates Source
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/updates/$releasever/SRPMS/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-source-f$releasever&arch=$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
# 

How can I back out to the original version of libxml2?  I initially tried to
"yum erase libxml2-python" but that wanted to remove over 100 packages,
including most of gnome...

Thanks

Harold
Comment 4 Seth Vidal 2007-07-01 11:22:43 EDT
grab libxml2 and libxml2-python from the original fc6 repo

http://download.fedora.redhat.com/pub/fedora/linux/core/6/i386/os/Fedora/RPMS/libxml2-2.6.26-2.1.1.i386.rpm
http://download.fedora.redhat.com/pub/fedora/linux/core/6/i386/os/Fedora/RPMS/libxml2-python-2.6.26-2.1.1.i386.rpm

then run:
rpm -Uvh --oldpackage libxml2-2.6.26-2.1.1.i386.rpm \ 
           libxml2-python-2.6.26-2.1.1.i386.rpm


that should do it.
Comment 5 Harold Pritchett 2007-07-01 22:20:20 EDT
Thanks for pointing me in the right direction.  I just needed to add
a couple of more packages to the list to be downgraded...

# rpm -Uvh --oldpackage \
      libxml2-2.6.26-2.1.1.i386.rpm \
      libxml2-python-2.6.26-2.1.1.i386.rpm \
      libxslt-1.1.17-1.1.i386.rpm \
      libxml2-devel-2.6.26-2.1.1.i386.rpm 
Preparing...                ########################################### [100%]
   1:libxml2                ########################################### [ 25%]
   2:libxslt                ########################################### [ 50%]
   3:libxml2-python         ########################################### [ 75%]
   4:libxml2-devel          ########################################### [100%]
# 

Thanks for the assistance

Harold

Note You need to log in before you can comment on or make changes to this bug.