Bug 246054 - F7 as guest crashes when reboot
F7 as guest crashes when reboot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-28 02:14 EDT by Ulrich Schreiner
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.22.1-41.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-10 18:14:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulrich Schreiner 2007-06-28 02:14:39 EDT
hi,

this is a bug in kvm which should be fixed in kvm-29. details of the bug

https://sourceforge.net/tracker/?func=detail&atid=893831&aid=1744028&group_id=180599

but: the current kvm in F7 is version 24, so i cannot use a F7 guest inside a
KVM machine. it would be great to update to kvm-29

thx
</usc>
Comment 1 Jeremy Katz 2007-06-28 10:33:43 EDT
The fix in question is in the kernel pieces of kvm, not the userspace side, so
some amount of coordination is going to be required to get the fix in.
Comment 2 Chuck Ebbert 2007-06-28 16:54:09 EDT
(In reply to comment #0)
> hi,
> 
> this is a bug in kvm which should be fixed in kvm-29. details of the bug
> 
>
https://sourceforge.net/tracker/?func=detail&atid=893831&aid=1744028&group_id=180599
> 

When I click on that link I get a completely blank page.
Comment 3 Ulrich Schreiner 2007-06-29 01:08:58 EDT
it is no problem, if some coordination is required. i only don't want to wait
for FC8 until the fix is officially included :-)



Comment 4 Chuck Ebbert 2007-06-29 13:52:33 EDT
I can't fix the bug if the only link I have to information about it leads to a
completely blank, empty web page.
Comment 5 Ulrich Schreiner 2007-06-29 14:27:29 EDT
sorry if the link does not work for you. if i click on the link i get the bug i
reported to the kvm project at sourceforge. so if the link does not work, go to
http://sourceforge.net/projects/kvm/ and in their bugtracker change the "Status"
to "Any" and look at bug 1744028. if you click on the details for the bug you
get this link

http://sourceforge.net/tracker/index.php?func=detail&aid=1744028&group_id=180599&atid=893831

(this time no https and with a "index.php", perhaps this link works)

so as far as i understand, the bug is fixed in kvm-29.
Comment 6 Avi Kivity 2007-06-29 16:05:23 EDT
This link works for me both on firefox and konqueror.
Comment 7 Chuck Ebbert 2007-06-29 16:33:39 EDT
kvm commit 030421334ae91b7f6302a1cfe9c971a8991b48 (reinit real-mode TSS)
was merged in kernel 1.3241.fc7

Should we just carry the latest kvm?
Comment 8 Avi Kivity 2007-06-29 18:55:27 EDT
kvm.git can be a good fit for rawhide (it would certainly increase the 
testbase for me).  Certainly not for F7.
Comment 9 Chuck Ebbert 2007-07-06 16:37:39 EDT
Patch is in kernel 2.6.21-1.3255.fc7, in updates-testing now.

Note You need to log in before you can comment on or make changes to this bug.