Bug 246060 - Some debuginfo libraries are stripped
Summary: Some debuginfo libraries are stripped
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openldap   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Jan Safranek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-28 08:32 UTC by Jan Safranek
Modified: 2009-01-20 20:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 20:53:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0090 normal SHIPPED_LIVE openldap bug fix and enhancement update 2009-01-20 16:04:26 UTC

Description Jan Safranek 2007-06-28 08:32:37 UTC
Description of problem:
Following libraries are stripped in openldap-2.3.27-8-debug
usr/lib/debug/usr/lib/tls/i586/libslapd_db-4.4.so.debug
usr/lib/debug/usr/lib/tls/i486/libslapd_db-4.4.so.debug

It's caused by linking i686/libslapd_db-4.4.so to i486 and i586 and rpmbuild
strips the i686 first.

Simple fix: use copy instead of link in the .spec file.
Workaround: copy i686/libslapd_db-4.4.so.debug to i486 and i586

Comment 1 RHEL Product and Program Management 2007-12-03 20:43:33 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.

Comment 2 RHEL Product and Program Management 2008-06-24 12:54:28 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 7 errata-xmlrpc 2009-01-20 20:53:30 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0090.html


Note You need to log in before you can comment on or make changes to this bug.