Bug 246092 - system-switch-mail uses chkconfig --add and --del, should use chkconfig on and off.
system-switch-mail uses chkconfig --add and --del, should use chkconfig on an...
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-switch-mail (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-28 10:16 EDT by Gary Benson
Modified: 2008-03-07 13:46 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-07 13:46:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gary Benson 2007-06-28 10:16:22 EDT
Description of problem:
system-switch-mail uses 'chkconfig --add MTA' and 'chkconfig --del MTA'.  It
would be more correct to do 'chkconfig MTA on' and 'chkconfig MTA off'. 
chkconfig --add and --del are only really intended to be used from within rpm
packages' %post and %postun scripts.  (Though it would be prudent for
system-switch-mail to do a chkconfig --add before doing the chkconfig on).

Version-Release number of selected component (if applicable):
system-switch-mail-0.5.25-12

How reproducible:
Always

Steps to Reproduce:
1. Install sendmail and postfix.
2. chkconfig --list | grep 'sendmail\|postfix'
  postfix         0:off   1:off   2:off   3:off   4:off   5:off   6:off
  sendmail        0:off   1:off   2:on    3:on    4:on    5:on    6:off
3. Switch to postfix using system-switch-mail.
4. chkconfig --list | grep 'sendmail\|postfix'

Actual results:
postfix         0:off   1:off   2:off   3:off   4:off   5:off   6:off

Expected results:
postfix         0:off   1:off   2:on    3:on    4:on    5:on    6:off
sendmail        0:off   1:off   2:off   3:off   4:off   5:off   6:off
Comment 1 Ngo Than 2008-03-07 13:46:29 EST
it's fixed in 0.5.26-1. Please reopen it if we want to fix it for RHEL-5.3 
update.

Note You need to log in before you can comment on or make changes to this bug.