Bug 246101 - Koji fails with inscrutable kerberos-related error message if fedora-packager-setup.sh has not been run
Koji fails with inscrutable kerberos-related error message if fedora-packager...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: koji (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-28 10:57 EDT by Carl Worth
Modified: 2013-01-09 20:40 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:49:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Carl Worth 2007-06-28 10:57:21 EDT
Description of problem:

The first time I tried using koji instead of brew it failed
inscrutably giving me a kerberos-related error message. I finally
pushed past the problem by running fedora-packager-setup.sh, but it
was not at all clear to me that that was what I needed to do.

Version-Release number of selected component (if applicable):

I don't know:

	$ koji --version
	usage: koji [global-options] command [command-options-and-arguments]

	koji: error: no such option: --version

Steps to Reproduce:
1. Move ~/.koji away temporarily
2. Run a "koji build" command, (such as through "make build")
  
Actual results:

Kerberos authentication failed: 'Server not found in Kerberos database'
(-1765328377)

Expected results:

What would be great is if instead of the bogus complaint about
kerberos that koji would direct the user to run
fedora-packager-setup.sh. What would be even better is if it simply
ran that script itself, (or otherwise arranged for all necessary
certificates and user-specific configuration to be created).
Comment 1 Carl Worth 2007-06-28 10:58:24 EDT
Fixing typo in bug title.
Comment 2 Mike McLean 2007-06-28 18:07:01 EDT
While I'm sure we can say something a little more helpful when this particular
error occurs, I think we should keep in mind that someone may well want to use
the koji build we ship in extras to talk to koji instances besides fp.org. For
this reason I don't think automatically running fedora-packager-setup.sh is
appropriate. If we do include a message with instructions, it should be clear
that fedora-packager-setup.sh is specific to the fedora koji server.
Comment 3 Jesse Keating 2007-11-15 11:49:46 EST
Filed upstream as https://hosted.fedoraproject.org/projects/koji/ticket/56 
Closing this bug here, will fix upstream.
Comment 4 Jiri Popelka 2010-02-02 08:59:10 EST
I never had problems with Koji, but today every time I try 'make build'
I always get

Kerberos authentication failed: Server not found in Kerberos database (-1765328377)
make: *** [build] Error 1

I tried to download a client side certificate from Fedora Account System and run fedora-packager-setup but it didn't work.
Can you somehow help me ?
Comment 5 Jesse Keating 2010-02-02 11:05:06 EST
(In reply to comment #4)
> I never had problems with Koji, but today every time I try 'make build'
> I always get
> 
> Kerberos authentication failed: Server not found in Kerberos database
> (-1765328377)
> make: *** [build] Error 1
> 
> I tried to download a client side certificate from Fedora Account System and
> run fedora-packager-setup but it didn't work.
> Can you somehow help me ?    

You are likely running into problems because you're using a mead version of koji.  Please make sure you're using the koji that comes from Fedora if you're on a Fedora system.
Comment 6 Jiri Popelka 2010-02-02 11:19:55 EST
Yes, I have 1.3.2-2.mead.1.fc12
Thanks for your advice.

Note You need to log in before you can comment on or make changes to this bug.