Bug 246109 - remove unused var in alloc_ldt()
Summary: remove unused var in alloc_ldt()
Status: CLOSED DUPLICATE of bug 234580
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.0
Hardware: All Linux
low
low
Target Milestone: ---
: ---
Assignee: Jerome Marchand
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-28 15:56 UTC by Jason Baron
Modified: 2013-03-06 05:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-29 09:07:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0791 normal SHIPPED_LIVE Updated kernel packages available for Red Hat Enterprise Linux 4 Update 6 2007-11-14 18:25:55 UTC

Description Jason Baron 2007-06-28 15:56:39 UTC
Description of problem:



Version-Release number of selected component (if applicable):

 remove unused var in alloc_ldt() 


How reproducible:




Steps to Reproduce:
This is very simple. The 4g4g patch removes all the accesses to the
'oldsize' variable in alloc_ldt(), except one now useless assignment and the
variable declaration. This patch fully remove the useless variable.
I test it using the 223851 reproducer which make heavy use of this part of
code.


1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 RHEL Product and Program Management 2007-06-28 16:05:58 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 2 Jason Baron 2007-06-28 19:49:44 UTC
committed in stream U6 build 55.14. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/


Comment 3 Jerome Marchand 2007-06-29 09:07:40 UTC

*** This bug has been marked as a duplicate of 234580 ***


Note You need to log in before you can comment on or make changes to this bug.