Bug 246137 - kernel build fails with given config file - NLA_BINARY
kernel build fails with given config file - NLA_BINARY
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-28 14:53 EDT by Thomas Steudten
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 15:37:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel config file (66.09 KB, text/plain)
2007-06-28 14:53 EDT, Thomas Steudten
no flags Details

  None (edit)
Description Thomas Steudten 2007-06-28 14:53:15 EDT
Source:  kernel-2.6.21-1.3228.fc7.src.rpm
Build with given config-file: rpmbuild -ba --target i686 kernel.spec fails with:

drivers/video/aty/radeon_base.c: In function 'radeonfb_pci_register':
drivers/video/aty/radeon_base.c:2321: warning: ignoring return value of
'sysfs_create_bin_file', declared with attribute warn_unused_result
drivers/video/aty/radeon_base.c:2323: warning: ignoring return value of
'sysfs_create_bin_file', declared with attribute warn_unused_result
sound/pci/pcxhr/pcxhr.c: In function 'pcxhr_trigger':
sound/pci/pcxhr/pcxhr.c:640: warning: 'stream' may be used uninitialized in this
function
net/ipv6/ip6_fib.c: In function 'fib6_add_rt2node':
net/ipv6/ip6_fib.c:661: warning: label 'out' defined but not used
net/wireless/nl80211.c:79: error: 'NLA_BINARY' undeclared here (not in a function)
make[2]: *** [net/wireless/nl80211.o] Error 1
make[1]: *** [net/wireless] Error 2
make: *** [net] Error 2
+ exit 1
error: Bad exit status from /var/tmp/rpm-tmp.80231 (%build)
Comment 1 Thomas Steudten 2007-06-28 14:53:15 EDT
Created attachment 158152 [details]
kernel config file
Comment 2 Christopher Brown 2007-09-17 15:37:38 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I don't think we can troubleshoot personal configuration files. If you are at
the point where you are building a custom kernel because the stock kernel
doesn't do as you ask then you should be prepared to troubleshoot whatever
issues you have compiling it. You can also put in an enhancement request if the
kernel is missing an option you would like.

Therefore I'm closing this as WONTFIX - I realise this was a few months back but
if you feel I am wrong to do this please re-open but with comment to the above.

Cheers
Chris

Note You need to log in before you can comment on or make changes to this bug.