Bug 246143 - Python error while runing mock
Python error while runing mock
Status: CLOSED NOTABUG
Product: Fedora Hosted Projects
Classification: Retired
Component: mock (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Clark Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-28 15:43 EDT by Frank Büttner
Modified: 2013-01-09 23:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-06 22:51:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Büttner 2007-06-28 15:43:37 EDT
Description of problem:
When I run "mock --autocache -r fedora-7-i386 init" under FC6 I will get an error.

Version-Release number of selected component (if applicable):
mock-0.7.2-1.fc6.1

 
Actual results:
init
clean
prep
This may take a while
Traceback (most recent call last):
  File "/usr/bin/mock", line 1140, in ?
    main()
  File "/usr/bin/mock", line 1078, in main
    do_clean(config_opts, init=1)
  File "/usr/bin/mock", line 938, in do_clean
    if init: my.prep()
  File "/usr/bin/mock", line 262, in prep
    self.yum(cmd)
  File "/usr/bin/mock", line 280, in yum
    (retval, output) = self.do(command)
  File "/usr/bin/mock", line 607, in do
    w.write(line)
IOError: [Errno 32] Broken pipe
create cache



Expected results:
none error
Comment 1 Julian Sikorski 2007-07-16 09:26:53 EDT
Happens with mock-0.7.2-1.fc7.x86_64 under f7 as well. This is most likely not
caused by mock itself, since it was working OK few days ago and no mock update
was shipped.
Comment 2 Clark Williams 2008-03-07 16:04:03 EST
yeah, it was probably a python update. Would you try the latest version of mock
(0.9.7+) and see if this is fixed?

Note You need to log in before you can comment on or make changes to this bug.