Bug 246232 - ACPI/IDE controller problems with ali chipset: unable to derive IRQ
Summary: ACPI/IDE controller problems with ali chipset: unable to derive IRQ
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7
Hardware: i686 Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-29 13:39 UTC by Atte Kojo
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-19 10:47:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel dmesg output (17.95 KB, text/plain)
2007-06-29 13:39 UTC, Atte Kojo
no flags Details

Description Atte Kojo 2007-06-29 13:39:41 UTC
Description of problem:
kernel fails to determine IRQ for the IDE controller on ali15x3 chipset, which 
causes all kinds of stability problems. (see dmesg)

Version-Release number of selected component (if applicable):
2.6.21-1.3228.fc7

How reproducible:
Use the computer for a while.

Actual results:
X (or even kernel) freezes completely from time to time.

Expected results:
System is stable.

Additional info:
The system works fine when run with acpi off, but since it is a laptop (HP 
Omnibook vt6200), having no cpu frequency scaling eats up the battery pretty 
quickly.

This is a know bug, see 
http://www.uwsg.iu.edu/hypermail/linux/kernel/0704.2/1078.html. I just 
reported it here so that others may find it, too.

Comment 1 Atte Kojo 2007-06-29 13:39:41 UTC
Created attachment 158204 [details]
kernel dmesg output

Comment 2 Atte Kojo 2007-06-29 13:40:51 UTC
Here's the lspci output from the computer:

00:00.0 Host bridge: ALi Corporation M1671 Super P4 Northbridge [AGP4X,PCI and 
SDR/DDR] (rev 02)
00:01.0 PCI bridge: ALi Corporation PCI to AGP Controller
00:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:04.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link 
Controller Audio Device (rev 02)
00:06.0 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
00:07.0 ISA bridge: ALi Corporation M1533/M1535 PCI to ISA Bridge [Aladdin 
IV/V/V+]
00:08.0 Ethernet controller: Realtek Semiconductor Co., Ltd. 
RTL-8139/8139C/8139C+ (rev 10)
00:09.0 Network controller: Intersil Corporation Prism 2.5 Wavelan chipset 
(rev 01)
00:0a.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller 
(rev 02)
00:0b.0 Communication controller: ESS Technology ES2838/2839 SuperLink Modem 
(rev 01)
00:0f.0 IDE interface: ALi Corporation M5229 IDE (rev c4)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M6 LY

Comment 3 Atte Kojo 2007-08-01 06:56:25 UTC
This still exists in kernel-2.6.22.1-33.fc7

Comment 4 Christopher Brown 2007-09-17 20:16:06 UTC
Hello Atte,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris

Comment 5 Atte Kojo 2007-09-19 06:29:44 UTC
Sorry, the laptop wasn't really usable in its current state, so I installed 
FreeBSD on it. 

Maybe monitor lkml and see if the bug gets fixed? Or just close as CANTFIX?

Comment 6 Christopher Brown 2007-09-19 10:47:46 UTC
Okay Atte. Thanks for filing anyway.

Cheers
Chris


Note You need to log in before you can comment on or make changes to this bug.