This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 246240 - Need multilib keyutils-libs
Need multilib keyutils-libs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: distribution (Show other bugs)
5.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Dennis Gregorovic
Daniel Riek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-29 10:52 EDT by Nalin Dahyabhai
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHEA-2007-0854
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 11:42:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 2007-06-29 10:52:19 EDT
Description of problem:
In order to support the use of KEYRING: credentials caches (as opposed to the
default FILE: form), Kerberos needs the keyutils libraries.  The Kerberos
libraries are multilib, but the keyutils libraries aren't.

Version-Release number of selected component (if applicable):
krb5-1.6.1-9.el5

How reproducible:
Always

Steps to Reproduce:
1. Attempt to install the non-native krb5-libs package (version 1.6.1).
  
Actual results:
Failure due to missing non-native keyutils-libs.

Expected results:
Success.

Additional info:
We seem to have multilib keyutils-libs-devel in the channel, which installs a
dangling symlink to a file in the corresponding keyutils-libs, which isn't in
the channel.
Comment 4 Dennis Gregorovic 2007-07-03 16:43:46 EDT
mutlilib keyutils-libs is already in the 5.1 nightlies.  It appears that
krb5-devel-1.6.1-10.el5 now requires libkeyutils.so.1 and that is pulling it in
automatically.
Comment 5 Nalin Dahyabhai 2007-07-05 14:59:51 EDT
If the symlink from libkeyutils.so in keyutils-libs-devel to libkeyutils.so.1 in
keyutils-libs didn't pull it in before that, that might indicate a different
problem.
Comment 7 Milan Zazrivec 2007-08-30 12:47:36 EDT
Verified with RHEL5.1-Server-20070822.1 and RHEL5.1-Client-20070822.5.
Comment 9 errata-xmlrpc 2007-11-07 11:42:30 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0854.html

Note You need to log in before you can comment on or make changes to this bug.