Bug 246263 - Mouse wheel not working
Mouse wheel not working
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-06-29 13:20 EDT by Klaus-Peter Schrage
Modified: 2009-10-22 08:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-07-14 14:03:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
X log file (30.59 KB, text/plain)
2007-06-29 13:23 EDT, Klaus-Peter Schrage
no flags Details
X log file after X had started without xorg.conf (21.52 KB, text/plain)
2007-07-02 12:52 EDT, Klaus-Peter Schrage
no flags Details
/var/log/Xlog.0 (57.23 KB, text/plain)
2008-09-12 15:14 EDT, Gene Czarcinski
no flags Details
/var/log/messages (49.22 KB, text/plain)
2008-09-12 15:20 EDT, Gene Czarcinski
no flags Details

  None (edit)
Description Klaus-Peter Schrage 2007-06-29 13:20:09 EDT
Description of problem:
I have a Logitech V270 cordless bluetooth mouse attatched to my Apple Ibook G4.
The mouse wheel works as a third button, but it won't scroll. It used to scroll
properly in FC 6, so I copied this portion of xorg.conf over to Fedora 7:

Section "InputDevice"
        Identifier  "mouse0"
        Driver      "mouse"
        Option      "Device" "/dev/input/mice"
        Option      "Protocol" "auto"
        Option      "ZAxisMapping" "4 5"

I have experimented a great deal with various Options that others proposed to be
relevant (Buttons, Protocol, Emulate3Buttons,...), but that wouldn't change
mouse behaviour.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start X
2. Load document or browser page long enough to show a vertical scroll bar
3. move mouse wheel
Actual results:

Expected results:

Additional info:
Comment 1 Klaus-Peter Schrage 2007-06-29 13:23:29 EDT
Created attachment 158225 [details]
X log file
Comment 2 Matěj Cepl 2007-07-02 03:48:44 EDT
Could you test what happens when you rename /etc/X11/xorg.conf to something else
and restart X?
Comment 3 Klaus-Peter Schrage 2007-07-02 12:50:41 EDT
(In reply to comment #2)
> Could you test what happens when you rename /etc/X11/xorg.conf to something else
> and restart X?

X wouldn't start (see log).
So, as a test, I deleted both Input Device sections for the mouse and the touch
pad (Synaptics driver) in xorg.conf, as well as the corresponding lines in the
Server Layout section. 

After restarting X, the behavior of the mouse hadn't noticeably changed - it
worked, but no scrolling.
Comment 4 Klaus-Peter Schrage 2007-07-02 12:52:26 EDT
Created attachment 158347 [details]
X log file after X had started without xorg.conf
Comment 5 Matěj Cepl 2007-07-03 03:45:47 EDT
(In reply to comment #3)
> X wouldn't start (see log).

ajax, does automagic self-configuration work with framebuffer?
Comment 6 Klaus-Peter Schrage 2007-11-23 13:25:20 EST
The bug reported above remains on Fedora 8 ...
Additional info: When I plug in a USB wheel mouse (Logitech MX300), it is
recognized immediately, with the wheel working as expected. So just a shot in
the dark: Is it possible that the bug is not X related but rather a
Bluetooth/HID/HCI issue (sorry, don't know much about this stuff)?
Comment 7 Gene Czarcinski 2008-05-02 10:39:26 EDT
Still not working as of this date (also does not work on f9-preview so I expect
it will not work on Fedora 9 when released).

My solution is to add the kernel (cmdline) parameter:  psmouse.proto=imps

Once added, the whell works fine.  The device is a Logitech Trackman Wheel

With f9's anaconda no longer having the ability top specify kernel parameters,
this is a bigger pain.

I am raising the priority ... hopefull someone will at least look at this report.
Comment 8 Bug Zapper 2008-05-13 23:01:00 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
Comment 9 Peter Hutterer 2008-07-17 19:57:45 EDT
can you please provide a log file, I'd like to have a look at the device
configuration in F9.

sounds like a hw/kernel/... issue. Your input device section points at
/dev/input/mice, which means X doesn't actually see that a new mouse is plugged
in. If the logitech's wheel works, this indicates that it's the other mouse.
Either in the kernel, the hardware or as you said the BT stack.
Comment 10 Gene Czarcinski 2008-09-12 15:14:53 EDT
Created attachment 316609 [details]

system is F9 plus all updates as of 12 Sep 2008 ... system is booted with cmdline parameter psmouse.proto=imps
Comment 11 Gene Czarcinski 2008-09-12 15:20:29 EDT
Created attachment 316611 [details]

system just booted before grabbing this file ... it goes with the Xlog file above

BTW, it may be a bit of a pain to add this but has worked for me for years now.

In the interest of complete honesty, my systems also include a Belkin 8-port KVM switch between the wheel-trackball and the computer.  However, MS Windows does not seem to have any problems with this configuration (wheel works).
Comment 12 Peter Hutterer 2008-09-14 20:57:03 EDT

The log indicates nothing out of the ordinary. Your mouse is added to the server through the evdev driver, a driver that relies on the kernel to deal with protocol-specific issues. xorg-x11-drv-mouse on the other hand deals with PS/2 directly.
My guess is that the KVM switch confuses the in-kernel driver so that it does not export wheel events to userspace.

Reassigning to kernel.
Comment 13 Bug Zapper 2009-06-09 18:40:45 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 14 Bug Zapper 2009-07-14 14:03:18 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.