Bug 246272 - avc denied {write} for comm="vgs" / comm="vgchange"
Summary: avc denied {write} for comm="vgs" / comm="vgchange"
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2
Version: 5.1
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Milan Broz
QA Contact: Corey Marthaler
URL:
Whiteboard:
Keywords: Regression, Reopened
: 241554 356351 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-29 18:31 UTC by Alexander Todorov
Modified: 2013-03-01 04:05 UTC (History)
11 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2007-11-07 16:49:16 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0516 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2007-10-30 16:18:33 UTC

Comment 6 Daniel Walsh 2007-07-02 20:24:16 UTC
Ok the problem here is that the directory /etc/lvm/cache is not defined in the
spec file so it does not get created by default, but only gets created when the
first lvm app runs.  This is not allowed by selinux policy.  This directory
should be created by the spec file, so it gets cleaned up correctly when the rpm
gets removed.  So I am reassigning this to lvm.

We tested this by making the directory and then rebooting.  AVC disappears.

Comment 10 Alexander Todorov 2007-08-29 12:34:09 UTC
not seeing this issue with lvm2-2.02.26-3.el5.
moving to VERIFIED

Comment 12 errata-xmlrpc 2007-11-07 16:49:16 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0516.html


Comment 13 Alasdair Kergon 2007-11-21 19:15:00 UTC
*** Bug 241554 has been marked as a duplicate of this bug. ***

Comment 14 Milan Broz 2008-01-04 13:17:39 UTC
*** Bug 356351 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.