Bug 246288 - Sound is broken on PowerBook G4 867Mhz
Sound is broken on PowerBook G4 867Mhz
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
powerpc Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-29 16:12 EDT by Bennett Feitell
Modified: 2007-12-03 12:35 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-03 12:35:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
current output of lsmod (2.13 KB, text/plain)
2007-06-29 16:12 EDT, Bennett Feitell
no flags Details
Tar of /proc/device-tree (25.62 KB, application/x-gzip)
2007-06-29 16:28 EDT, Bennett Feitell
no flags Details

  None (edit)
Description Bennett Feitell 2007-06-29 16:12:06 EDT
Sound is completely broken on my Powerbook G4 Titanium (867Mhz).

On a clean install snd-powermac is included in /etc/modprobe.conf
This does not work.  Tried re-detecting soundcard vis system-config-soundcard. 
The modules set up this way do not work either.  

Based on advice in #fedora-ppc on freenode.net, added modprobe statements for
the snd-aoa modules.  This does not work either.  

No sound under Gnome, no sound under KDE.

Here is a link to similar reports in the Ubuntu bug handling system.  It seems
likely to be a kernel issue:
https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/87652

I am not sure where to file this within Bugzilla for F7.

Sound worked perfectly on this machine under FC6.
Comment 1 Bennett Feitell 2007-06-29 16:12:06 EDT
Created attachment 158259 [details]
current output of lsmod
Comment 2 Bennett Feitell 2007-06-29 16:28:53 EDT
Created attachment 158261 [details]
Tar of /proc/device-tree

Please not Kernel currently tainted by Atheros (MadWIFI).  Reported problem is
independent of taint.
Comment 3 Christopher Brown 2007-09-17 16:18:00 EDT
Hello Bennett,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris
Comment 4 Will Woods 2007-12-03 12:35:46 EST
No response from reporter, and sound works fine on my G4 PowerBook. 

Note You need to log in before you can comment on or make changes to this bug.