Bug 246370 - Bad package update url causes package manager to fail and exit
Bad package update url causes package manager to fail and exit
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-01 02:39 EDT by Steve Russ
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-06 16:21:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Russ 2007-07-01 02:39:37 EDT
Newbie...just trying linux for the first time...so please bear with me.

Description of problem: 2 problems

1) Bad package update url causes package manager to fail and exit. Cannot
add/remove packages or update.

2) After failure Details shows None...leaves user clueless.

How reproducible:
100% on my installation. Failure locks me out of all updates thru GUI and
command line both.

Steps to Reproduce:
Not sure how I got into this problem with Adobe package but I'll bet the problem
is same with any package. 

Understand that I don't know enough yet about linux to go outside of the
GUI...so I haven't yet...until my fedora bible arrives.

When I choose applications>add/remove software...I get an error dialog that says
"Unable to retrieve software information"

When I expand the details it says ">Details NONE". 

Additional info:
Forum member walked me thru using the console for the first time to run yum
update...

[root@localhost ~]# yum update
Loading "installonlyn" plugin
Setting up Update Process
http://linuxdownload.adobe.com/linu...ata/repomd.xml: [Errno 14] HTTP Error 404:
Date: Fri, 29 Jun 2007 17:37:13 GMT
Server: Apache
Transfer-Encoding: chunked
Content-Type: text/html; charset=iso-8859-1

Trying other mirror.
Error: Cannot open/read repomd.xml file for repository: adobe-linux

Went for a cup of coffee and when I returned there was this addition to the
console...

You have new mail in /var/spool/mail/root
[root@localhost ~]#

So I went hunting and found these entries in the mail file:

################### Logwatch 7.3.4 (02/17/07) ####################
Processing Initiated: Fri Jun 29 10:54:29 2007
Date Range Processed: yesterday
( 2007-Jun-28 )
Logfiles for Host: localhost.localdomain
################################################## ################

--------------------- Connections (secure-log) Begin ------------------------
Userhelper executed applications:
root -> system-config-network as root: 2 Time(s)
root -> pirut as root: 4 Time(s)
steve -> pup as root: 2 Time(s)
steve -> pirut as root: 5 Time(s)
steve -> adobe-release-1.0-0.noarch.rpm as root: 1 Time(s)
steve -> system-config-network as root: 2 Time(s)
root -> pup as root: 1 Time(s)
steve -> system-config-securitylevel.py as root: 1 Time(s)
---------------------- Connections (secure-log) End -------------------------

--------------------- yum Begin ------------------------
Packages Installed:
gutenprint-plugin.x86_64 5.0.0.99.1-3.fc7
adobe-release.noarch 1.0-0

Packages Updated:
gnome-games.x86_64 2.18.2.1-2.fc7
metacity.i386 2.18.5-1.fc7
vte.x86_64 0.16.6-1.fc7
...

.......so it looks like adobe got installed [I don't remember asking for this to
happen]and it is trying to update...and failing.

I don't know where to begin to fix this...but I am enjoying [learning to use]
the console.

Steve
Comment 1 Steve Russ 2007-07-06 00:29:00 EDT
I know it's july 4th and all...but I don't know how to fix this problem. Only
know how to reinstall [I'm getting pretty good at it]. I'll wait for another 48
hours and if nobody needs any additonal information about my setup I'm going to
wipe it and start over [hopefully without adobe this time].

This problem is important for newbies...please look into it.
Comment 2 Jeremy Katz 2007-07-06 16:21:24 EDT
At some point, you've installed the adobe repo and their package is broken.  You
can either
  yum remove adobe-release
or edit /etc/yum.repos.d/adobe.repo and disable the repo 
Comment 3 Steve Russ 2007-07-07 00:53:02 EDT
Jeremy...Thanks for the workaround...however IF the fedora evangelists are
hoping that the GUI will work for everyone, then this problem should not be closed.

I may be a linux newbie, but I spent 4 yrs programming then 5 yrs as a QA
manager with Apple Computer. 

If this program manager encounters an error...at the very least it should return
the error to the user through the interface...at best it should skip the broken
package and continue allowing the user to install/remove all the other packages
that still are error free. 

Otherwise...why spend any time developing a GUI?

Note You need to log in before you can comment on or make changes to this bug.