Bug 246401 - Compile against system bzip2 library
Summary: Compile against system bzip2 library
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Compress-Raw-Bzip2   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Robin Norwood
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-01 20:31 UTC by Steven Pritchard
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-02 04:04:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to use system libbz2 (898 bytes, patch)
2007-07-01 20:31 UTC, Steven Pritchard
no flags Details | Diff
Proposed patch to spec (1.51 KB, patch)
2007-07-01 20:56 UTC, Steven Pritchard
no flags Details | Diff

Description Steven Pritchard 2007-07-01 20:31:57 UTC
The package I submitted for review had a patch to compile against the system 
libbz2 instead of the bundled one.  (It looks like I still didn't get it 100% 
right though...  Oops.)

The patch should be in the next Compress::Raw::Bzip2 according to 
http://rt.cpan.org/Public/Bug/Display.html?id=25489

Comment 1 Steven Pritchard 2007-07-01 20:31:58 UTC
Created attachment 158313 [details]
Patch to use system libbz2

Comment 2 Steven Pritchard 2007-07-01 20:43:42 UTC
And by not "100% right", I mean I didn't actually enable the behavior the 
patch was meant to enable.  I was still building against the bundled libbz2.

It *should* be as simple as just setting BZIP2_LIB=%{_libdir}, but it doesn't 
appear to be quite that easy.

Comment 3 Steven Pritchard 2007-07-01 20:54:10 UTC
Oh, wait, nevermind.  I should have re-read the patch.  You also have to set 
BUILD_BZIP2=0.

Comment 4 Steven Pritchard 2007-07-01 20:56:28 UTC
Created attachment 158314 [details]
Proposed patch to spec

- Update to 2.005.
- Build against system libbz2 (#246401).

Comment 5 Robin Norwood 2007-07-02 04:04:28 UTC
update to 2.005, with your patch.

Also updated the other 'Compress' packages to 2.005.


Note You need to log in before you can comment on or make changes to this bug.