Bug 246402 - lighttpd return a 400 - Bad Request error with a underline in http address ex: http://www.my_web.com.br
lighttpd return a 400 - Bad Request error with a underline in http address ex...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lighttpd (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-01 17:22 EDT by Itamar Reis Peixoto
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-02 00:57:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Itamar Reis Peixoto 2007-07-01 17:22:24 EDT
Description of problem:

lighttpd return a 400 - Bad Request error with a underline in http address ex:
http://www.my_web.com.br


Version-Release number of selected component (if applicable):

lighttpd-1.4.15-1.fc7

How reproducible:
access a website hosted by lighttpd with underline _ in address
example: 

http://www.my_web.com.br


Additional info:

In apache works fine
Comment 1 Matthias Saou 2007-07-02 00:57:02 EDT
Well, apache is too nice, I guess. Because underscores aren't RFC compliant in
domain names nor in host names. Fix your DNS entries...

This has already been reported and closed upstream :
http://trac.lighttpd.net/trac/ticket/1089

I have seen that RFC1033 does mention the underscore for DNS zones, so if you
feel like making an argument upstream with it, feel free, but this isn't
something I'll fix only in the package.

Note You need to log in before you can comment on or make changes to this bug.