Bug 24641 - GCC 2.96 Internal error when compiling UPX 1.04
Summary: GCC 2.96 Internal error when compiling UPX 1.04
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-22 20:16 UTC by bruns
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-28 15:02:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description bruns 2001-01-22 20:16:18 UTC
gcc  -DWITH_UCL '-DUPX_CONFIG_H="config_h/linux.h"' -I. -I/usr/src/u/ucl-0.92/include -Werror -O6 -mpentiumpro -march=pentiumpro 
-march=i386 -mcpu=pentium -Wsynth -fconserve-space -fno-exceptions -fno-rtti -o c_init.o -c c_init.cpp
c_init.cpp: In function `int set_fg (FILE *, int)':
c_init.cpp:111: Internal compiler error in emit_move_insn_1, at expr.c:
2830
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make: *** [c_init.o] Error 1

C++ Bomb.
Not much else to say for this one.  This is the standard UPX and UCL code at http://upx.tsx.org. If you want to do specific things, drop me an 
e-mail and I will give it a go...

gcc-c++-2.96-70
gcc-2.96-70

Linux kernel 2.4.0 with International patches
Hand compiled latest glibc CVS tree (glibc 2.2.1)
256 Megs of RAM on a Dual Proc PII 333.

Comment 1 Jakub Jelinek 2001-01-23 09:52:54 UTC
Can you please run
gcc  -DWITH_UCL '-DUPX_CONFIG_H="config_h/linux.h"' -I. -I/usr/src/u/ucl-0.92/include -Werror -O6 -mpentiumpro -march=pentiumpro
-march=i386 -mcpu=pentium -Wsynth -fconserve-space -fno-exceptions -fno-rtti -o c_init.o -c c_init.cpp -save-temps -v
and attach here c_init.ii this generates. ICEs are often dependant on the exact
content of all the headers which come into the game and preprocessing the source
is the easiest way how to make sure we're looking at the same thing.

Comment 2 bruns 2001-01-23 18:54:48 UTC
Alright, file generated.  But due to the fact I dont see any way to attach a file here (I may be blind and its sitting right in front of my face), I threw it up on 
my web server, URL is as follows.

http://www.magenet.com/bugzilla/c_init.ii

Comment 3 Jakub Jelinek 2001-01-28 15:02:21 UTC
I've commited a fix for this to CVS gcc and the patch will appear
in gcc-c++-2.96-73.
See http://gcc.gnu.org/ml/gcc-patches/2001-01/msg02070.html

Comment 4 Jakub Jelinek 2001-02-05 21:05:17 UTC
Fix is in 2.96-73 and above (currently -74).


Note You need to log in before you can comment on or make changes to this bug.