Bug 246411 - blender requires libalut to start, but the package doesn't depend on it
blender requires libalut to start, but the package doesn't depend on it
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: blender (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-01 22:09 EDT by Matt Everingham
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-09 15:34:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of rpm -qRp blender-2.4.4-4.fc7 (1.09 KB, text/plain)
2007-07-02 11:41 EDT, Jochen Schmitt
no flags Details
Output of requested command (984 bytes, text/plain)
2007-07-04 15:32 EDT, Matt Everingham
no flags Details

  None (edit)
Description Matt Everingham 2007-07-01 22:09:13 EDT
Description of problem:

installed blender with "yum install blender"
and when typing "blender" on the command line, I get:

/usr/bin/blender.bin: error while loading shared libraries: libalut.so.0: cannot
open shared object file: No such file or directory

This prevented blender from starting at all.  Manually installing package
"freealut" fixed the issue, but it seems that the blender package should depend
on freealut if it is needed to run.

Version-Release number of selected component (if applicable):
f7, fresh install

How reproducible:
I just have one fedora machine to try it on and it is fixed now, but got the
same result on this machine every time I tried it.

Steps to Reproduce:
1. "yum install blender" (as root...)
2. "blender"
3.
  
Actual results:

/usr/bin/blender.bin: error while loading shared libraries: libalut.so.0: cannot
open shared object file: No such file or directory

Expected results:

blender should start

Additional info:
This is a pretty small bug, but could be a show stopper for the less technically
inclined.
Comment 1 Jochen Schmitt 2007-07-02 11:41:27 EDT
Created attachment 158339 [details]
Output of rpm -qRp blender-2.4.4-4.fc7
Comment 2 Jochen Schmitt 2007-07-02 11:45:14 EDT
It will be nice, if you can do the following:

1.) Download the RPM Package from the repository

2.) type in 'rpm -qRp blender-2.4.4-4.fc7....'

I have attached the output from my machine on comment #1

On my requirement list I can found a requirement to libalut.so.0
Comment 3 Matt Everingham 2007-07-04 15:32:14 EDT
Created attachment 158543 [details]
Output of requested command
Comment 4 Matt Everingham 2007-07-04 15:38:42 EDT
Comment on attachment 158543 [details]
Output of requested command

Oddly, mine also lists that libalut.so.0
Comment 5 Jochen Schmitt 2007-07-09 15:34:28 EDT
I have assume, that this may be caused by the fact, that the earlier version of
blender was available for i386 only. But my tests shows, that the update path
woring properly.

So I have no idea, why this may be happen. I assume, that was a yum/rpm/repodata
issue, which maybe fixed now. So I want to close this bug now.

Note You need to log in before you can comment on or make changes to this bug.