Bug 246449 - Attach file doesn't work if Thunderbird already open
Attach file doesn't work if Thunderbird already open
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-02 06:08 EDT by Lorenzo Fiorini
Modified: 2008-02-28 10:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 10:14:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 296635 None None None Never

  None (edit)
Description Lorenzo Fiorini 2007-07-02 06:08:03 EDT
Description of problem:
Openoffice File Send as attachment doesn't works if Thunderbird is already open. 

Version-Release number of selected component (if applicable):
f7, Thunderbird 2.0.0.4

How reproducible:
always


Steps to Reproduce:
1. start thunderbird
2. start OpenOffice Word Processor
3. choose File/Send/Document as Email
  
Actual results:
To:attachment=file:///tmp/sv9nm.tmp/sva00.tmp/noname.odt


Expected results:
noname.odt as attachment


Additional info:
This "bug" exit since years, in fact every new Fedora release or Thunderbird
update I have to "fix" /usr/bin/thunderbird compose as below.
Note that "standard" Thunderbird from mozilla.org works as expected.
OpenOffice is used only for example even calling thunderbird -compose from
command line expose the "bug".

    -compose)
        shift
        if [ "${ALREADY_RUNNING}" -eq "1" ]; then
            # remove 'mailto:' prefix
            ARGS="`echo $@ | sed 's/^mailto://'`"
# ---------> changed 
#            exec $MOZ_CLIENT_PROGRAM "mailto($ARGS)"
            exec $MOZ_CLIENT_PROGRAM xfeDoCommand(ComposeMessage,$ARGS)"
# ---------> changed
        else
            rm_shit
            exec $MOZ_PROGRAM $MOZARGS -compose "$@"
        fi
        ;;
Comment 1 Matěj Cepl 2008-02-28 10:14:14 EST
We found that this bug has been already registered in the upstream database
(https://bugzilla.mozilla.org/show_bug.cgi?id=296635) and believe that it is
more appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug
tracker, and will review any bug fixes that become available for consideration
in future updates.

Thank you for the bug report.

Note You need to log in before you can comment on or make changes to this bug.