Bug 246515 - Amanda still has issues with large holding disks
Amanda still has issues with large holding disks
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: amanda (Show other bugs)
5.0
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Petr Hracek
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-02 15:31 EDT by Randy Zagar
Modified: 2013-03-07 07:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-07 07:13:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Zagar 2007-07-02 15:31:11 EDT
Description of problem:
Several internal data structures in Amanda cannot cope with large holding disks.
 Data structures like "generic_fs_stat_t" and "holdingdisk_t" use LONG values to
store disk stats in units of Kilobytes.  This breaks when the size of the
holding disk is greater than 2-TB

Version-Release number of selected component (if applicable):
2.5.0p2-4

How reproducible:
Always...

Steps to Reproduce:
1. Configure Amanda with a 3-TB holding disk
2. Run "amcheck -s DailySet1"
3. Review source code, esp. the data structure definitions
4. Slap forehead
5. Say "Doh!"
  
Actual results:
[root@grendel-4 ~]# su -c "amcheck -s DailySet1" amanda
Amanda Tape Server Host Check
-----------------------------
WARNING: holding disk /lvm/amanda/holding/DailySet1: only -997551808 KB free,
using nothing
slot 6: read label `DailySet1-6', date `X'

NOTE: skipping tape-writable test
Tape DailySet1-6 label ok
Server check took 0.091 seconds

(brought to you by Amanda 2.5.0p2)


Expected results:
No warnings...

Additional info:
Comment 1 RHEL Product and Program Management 2007-12-03 15:43:40 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.
Comment 3 Simon Josi 2010-03-03 14:37:22 EST
We've fixed the issue with some additions to the big_holding_disk.patch:


--- amanda-2.5.0p2/common-src/statfs.c.big_holding_disk	2006-03-28 16:09:51.000000000 -0500
+++ amanda-2.5.0p2/common-src/statfs.c	2006-06-09 11:45:06.000000000 -0400
@@ -127,7 +127,7 @@
 # endif
 #endif
 
-#define scale(r,s)	( (r) == -1? -1 : (int)((r)*(double)(s)/1024.0) )
+#define scale(r,s)	( (r) == -1? -1 : (long long)((r)*(double)(s)/1024.0) )
 
 int get_fs_stats(dir, sp)
 char *dir;
--- amanda-2.5.0p2/common-src/statfs.h.big_holding_disk	2010-03-02 17:19:43.000000000 +0100
+++ amanda-2.5.0p2/common-src/statfs.h	2010-03-02 17:22:14.000000000 +0100
@@ -31,9 +31,9 @@
 #include "amanda.h"
 
 typedef struct generic_fs_stats {
-    long total;		/* total KB in filesystem */
-    long avail;		/* KB available to non-superuser */
-    long free;		/* KB free for superuser */
+    long long total;	/* total KB in filesystem */
+    long long avail;	/* KB available to non-superuser */
+    long long free;	/* KB free for superuser */
 
     long files;		/* total # of files in filesystem */
     long favail;	/* # files avail for non-superuser */
--- amanda-2.5.0p2/server-src/conffile.h.big_holding_disk	2010-03-03 11:34:03.000000000 +0100
+++ amanda-2.5.0p2/server-src/conffile.h	2010-03-03 12:03:44.000000000 +0100
@@ -267,7 +267,7 @@
 
     char *comment;
     char *diskdir;
-    long disksize;
+    long long disksize;
     long chunksize;
 
     int s_comment;
Comment 5 RHEL Product and Program Management 2010-08-09 14:26:53 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 7 RHEL Product and Program Management 2011-01-11 15:40:00 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2011-01-11 17:15:53 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 9 RHEL Product and Program Management 2011-05-31 09:28:57 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 10 RHEL Product and Program Management 2012-06-11 21:04:18 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 12 Petr Hracek 2013-03-07 07:13:03 EST
I am sorry, but it is too late in the RHEL-5 release cycle [1].  At the moment we are addressing only critical and security related issues in RHEL-5.  This one is fixed in RHEL-6.  I am closing the bug as NEXTRELEASE.

[1] https://access.redhat.com/support/policy/updates/errata/

Note You need to log in before you can comment on or make changes to this bug.