Bug 246546 - Missing Dependency: kdebase = 6:3.5.6-3.fc6 is needed by package kdebase-kdm
Missing Dependency: kdebase = 6:3.5.6-3.fc6 is needed by package kdebase-kdm
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
6
i686 Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-02 19:20 EDT by Tom Witmer
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-17 14:29:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Witmer 2007-07-02 19:20:46 EDT
Description of problem:
Cannot use yum update to update kde packages for FC6. Running 32-bit x86 FC6
with KDE environment and ran into this problem on June 29 which continues
through July 2nd so far:

# yum update
[...lots of KDE pkgs...]
Missing Dependency: kdebase = 6:3.5.6-3.fc6 is needed by package kdebase-kdm


The only repos I have enabled are core, extras, updates, livna, and macromedia.
I used to use kde-redhat.org, but disabled that some time recently when it
stopped responding:

# grep -l "^enabled=1" /etc/yum.repos.d/*
/etc/yum.repos.d/fedora-core.repo
/etc/yum.repos.d/fedora-extras.repo
/etc/yum.repos.d/fedora-updates.repo
/etc/yum.repos.d/livna.repo
/etc/yum.repos.d/macromedia-i386.repo

Someone on Fedoraforum.org noticed that the new version of kdebase appears to
obsolete kdebase-kdm, so this might just need a packaging tweak. 

Version-Release number of selected component (if applicable):
# rpm -q kdebase kdebase-kdm
kdebase-3.5.6-3.fc6
kdebase-kdm-3.5.6-3.fc6

How reproducible:
Easy, if you have an i686 FC machine with KDE.

Steps to Reproduce:
1. Run yum update on a i686 FC6 install with KDE
  
Actual results:
Missing Dependency: kdebase = 6:3.5.6-3.fc6 is needed by package kdebase-kdm

Expected results:
Successful yum update

Additional info:
Fedora forum posting on same topic:
http://forums.fedoraforum.org/forum/showthread.php?t=159790

Thanks for any help!
Comment 1 Rex Dieter 2007-07-03 05:51:12 EDT
Looks like a missing 
Obsoletes/Provides: kdebase-kdm (like on the F7+ branches, for kde-redhat
compatibility).

Quick-n-dirty fix: 
$ rpm -e kdebase-kdm
$ yum update
Comment 2 Tom Witmer 2007-07-03 11:22:37 EDT
Almost worked. I had to erase another package, but then the update failed again.

# rpm -e kdebase-kdm kde-settings-kdm  

Which now got me to:

Transaction Check Error:
  file /etc/kderc from install of kdebase-3.5.7-0.1.fc6 conflicts with file from
package kde-settings-3.5-18.fc6
  file /usr/share/config/clockappletrc from install of kdebase-3.5.7-0.1.fc6
conflicts with file from package kde-settings-3.5-18.fc6
  file /usr/share/config/kcmnspluginrc from install of kdebase-3.5.7-0.1.fc6
conflicts with file from package kde-settings-3.5-18.fc6
  file /usr/share/config/kdeglobals from install of kdebase-3.5.7-0.1.fc6
conflicts with file from package kde-settings-3.5-18.fc6
  file /usr/share/config/kdesktoprc from install of kdebase-3.5.7-0.1.fc6
conflicts with file from package kde-settings-3.5-18.fc6
  file /usr/share/config/kickerrc from install of kdebase-3.5.7-0.1.fc6
conflicts with file from package kde-settings-3.5-18.fc6
  file /usr/share/config/konquerorrc from install of kdebase-3.5.7-0.1.fc6
conflicts with file from package kde-settings-3.5-18.fc6
  file /usr/share/config/ksplashrc from install of kdebase-3.5.7-0.1.fc6
conflicts with file from package kde-settings-3.5-18.fc6
  file /usr/share/config/kwinrc from install of kdebase-3.5.7-0.1.fc6 conflicts
with file from package kde-settings-3.5-18.fc6
  file /usr/share/config/profilerc from install of kdebase-3.5.7-0.1.fc6
conflicts with file from package kde-settings-3.5-18.fc6


I'm going to try removing those files (or archiving them if I care) and see what
happens next.

Comment 3 Tom Witmer 2007-07-03 11:32:28 EDT
Hmm, deleting those files doesn't seem to help. A "kde-settings" package is now
in the way. I'm guessing this is some incompatibility in the transition from
kde-redhat.org to regular Fedora, but don't really know. Removing kde-settings
is a non-starter; it takes dozens of packages with it.

I'll hold off at this point; I probably can't get to run level 5 now, at least
now with KDE. 

Is there some way to force the update?

# ls -l /etc/kderc
ls: /etc/kderc: No such file or directory
whitebox.localdomain: /root
# ls -l /usr/share/config/clockappletrc
ls: /usr/share/config/clockappletrc: No such file or directory

# yum update
[...stuff deleted...]

Transaction Check Error:
  file /etc/kderc from install of kdebase-3.5.7-0.1.fc6 conflicts with file from
package kde-settings-3.5-18.fc6
  file /usr/share/config/clockappletrc from install of kdebase-3.5.7-0.1.fc6
conflicts with file from package kde-settings-3.5-18.fc6
  file /usr/share/config/kcmnspluginrc from install of kdebase-3.5.7-0.1.fc6
conflicts with file from package kde-settings-3.5-18.fc6
  file /usr/share/config/kdeglobals from install of kdebase-3.5.7-0.1.fc6
conflicts with file from package kde-settings-3.5-18.fc6
  file /usr/share/config/kdesktoprc from install of kdebase-3.5.7-0.1.fc6
conflicts with file from package kde-settings-3.5-18.fc6
  file /usr/share/config/kickerrc from install of kdebase-3.5.7-0.1.fc6
conflicts with file from package kde-settings-3.5-18.fc6
  file /usr/share/config/konquerorrc from install of kdebase-3.5.7-0.1.fc6
conflicts with file from package kde-settings-3.5-18.fc6
  file /usr/share/config/ksplashrc from install of kdebase-3.5.7-0.1.fc6
conflicts with file from package kde-settings-3.5-18.fc6
  file /usr/share/config/kwinrc from install of kdebase-3.5.7-0.1.fc6 conflicts
with file from package kde-settings-3.5-18.fc6
  file /usr/share/config/profilerc from install of kdebase-3.5.7-0.1.fc6
conflicts with file from package kde-settings-3.5-18.fc6

Comment 4 Rex Dieter 2007-07-17 14:17:36 EDT
this will likely yield something closer to working:
rpm -e --nodeps kde-settings
yum update

Else, re-enable kde-redhat, and you'll get fixed pkgs.
Comment 5 Rex Dieter 2007-07-17 14:29:16 EDT
or update to F-7, otherwise, kde-redhat's FC-6 pkgs are tracking F-7/ branch
enhancements.

Closing->NOTABUG (not a fedora one anyway).

Note You need to log in before you can comment on or make changes to this bug.