Bug 246581 - dangling symlink
Summary: dangling symlink
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openldap   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jan Safranek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-03 08:11 UTC by Florian La Roche
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-09 08:09:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Florian La Roche 2007-07-03 08:11:10 UTC
Description of problem:

[laroche@dudweiler Fedora]$ rpm -qplv compat-openldap-2.3.34_2.2.29-5.fc8.i386.rpm
lrwxr-xr-x    1 root    root               21 Jul  1 22:13
/usr/lib/liblber-2.2.so.7 -> liblber-2.2.so.7.0.22
-rwxr-xr-x    1 root    root            55520 Jul  1 22:15
/usr/lib/liblber-2.2.so.7.0.22
lrwxr-xr-x    1 root    root               21 Jul  1 22:13
/usr/lib/libldap-2.2.so.7 -> libldap-2.2.so.7.0.22
-rwxr-xr-x    1 root    root           221680 Jul  1 22:15
/usr/lib/libldap-2.2.so.7.0.22
lrwxr-xr-x    1 root    root               23 Jul  1 22:13
/usr/lib/libldap_r-2.2.so.7 -> libldap_r-2.2.so.7.0.22
-rwxr-xr-x    1 root    root           237364 Jul  1 22:15
/usr/lib/libldap_r-2.2.so.7.0.22
lrwxr-xr-x    1 root    root               18 Jul  1 22:13
/usr/sbin/compat-slapcat -> /usr/libexec/slapd
drwxr-xr-x    2 root    root                0 Jul  1 22:15
/usr/share/doc/compat-openldap-2.3.34_2.2.29
-rw-r--r--    1 root    root             3439 Jan 20  2005
/usr/share/doc/compat-openldap-2.3.34_2.2.29/ANNOUNCEMENT
-rw-r--r--    1 root    root             2241 Jan 20  2005
/usr/share/doc/compat-openldap-2.3.34_2.2.29/COPYRIGHT
-rw-r--r--    1 root    root             2214 Dec  1  2003
/usr/share/doc/compat-openldap-2.3.34_2.2.29/LICENSE


There is no file /usr/libexec/slapd in any of the
compat-openldap or openldap* rpm packages available.

regards,

Florian La Roche



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jan Safranek 2007-07-09 08:09:18 UTC
Thanks for the report, whole slapcat in compat package was completely broken...
Now (openldap-2.3.34-6.fc8) it can now be found in
/usr/lib/compat-openldap/slapcat, because it checks argv[0].


Note You need to log in before you can comment on or make changes to this bug.