Bug 246589 - lack of AMD/ATI SB600 SMBus Device ID
lack of AMD/ATI SB600 SMBus Device ID
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
All Linux
low Severity medium
: ---
: ---
Assigned To: Prarit Bhargava
Martin Jenner
: OtherQA
Depends On:
Blocks: 221318 248673
  Show dependency treegraph
 
Reported: 2007-07-03 05:27 EDT by Shane Huang
Modified: 2009-06-19 19:30 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2007-0791
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:29:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHEL4.6: fix for this issue (1.41 KB, patch)
2007-07-05 11:07 EDT, Prarit Bhargava
no flags Details | Diff

  None (edit)
Description Shane Huang 2007-07-03 05:27:12 EDT
Description of problem:
kernel source is lack of AMD/ATI SB600 SMBus Device ID

Version-Release number of selected component (if applicable):
kernel 2.6.9-42.E

How reproducible:
check the kernel source code: drivers/i2c/busses/i2c-piix4.c

Actual results:
Hardware monitor will not work on SB600 if it use SMBus.

Expected results:
Hardware monitor ought to work on SB600.
Comment 1 Shane Huang 2007-07-03 05:30:06 EDT
upstream commit:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-
2.6.git;a=commit;h=4e6697fcc194db8b45559a9863947c6cbfeea363

Please backport this patch into RHEL4.6,
Thanks
Comment 2 RHEL Product and Program Management 2007-07-03 10:45:19 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Prarit Bhargava 2007-07-03 13:27:05 EDT
It looks like a few other patches will be necessary to get the SB600 booting in
RHEL4.  I'm investigating now ....

bootlog looks like:

hci 0000:00:12.0: flags: 64bit ncq ilck pm led clo pmp pio slum part 
ata1: SATA max UDMA/133 cmd 0xFFFFFF000001C100 ctl 0x0 bmdma 0x0 irq 169
ata2: SATA max UDMA/133 cmd 0xFFFFFF000001C180 ctl 0x0 bmdma 0x0 irq 169
ata3: SATA max UDMA/133 cmd 0xFFFFFF000001C200 ctl 0x0 bmdma 0x0 irq 169
ata4: SATA max UDMA/133 cmd 0xFFFFFF000001C280 ctl 0x0 bmdma 0x0 irq 169
scsi0 : ahci
ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
ata1.00: qc timeout (cmd 0xec)
ata1.00: failed to IDENTIFY (I/O error, err_mask=0x104)
ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
ata1.00: qc timeout (cmd 0xec)
ata1.00: failed to IDENTIFY (I/O error, err_mask=0x104)
ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
ata1.00: qc timeout (cmd 0xec)
ata1.00: failed to IDENTIFY (I/O error, err_mask=0x104)
ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
scsi1 : ahci
ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)



P.
Comment 4 Prarit Bhargava 2007-07-03 14:04:27 EDT
Looks like 2.6.9.55-15.el boots just fine (and it has all my previous sb600
changes in it).

P.
Comment 5 Bhavna Sarathy 2007-07-03 15:01:23 EDT
Prarit, is it possible to attach the src rpm (2.6.9.55-15.el) to the bugzilla so
that the chipset group can test out the latest source on their systems?   

I'm working on the SB700 SMBus requirement and this may depends on the sb600
support.
Comment 6 Prarit Bhargava 2007-07-03 15:03:18 EDT
Actually, it's available externally from

http://people.redhat.com/~jbaron/rhel4

P.
Comment 7 Shane Huang 2007-07-04 02:26:41 EDT
I installed the latest kernel(2.6.9-55.16.EL) and find it boots well
on my board without the error above.

And I also checked the source of this kernel version, find the following
SB600 patches have NOT been included, you may check it:
(1) IDE has only one channel:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-
2.6.git;a=commit;h=b25168dfdc162b4198fa6395cd191a20dddc6d34

(2) IDE HDD may not work if using a 40-pin PATA cable
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-
2.6.git;a=commit;h=e5c073ff24604d4dbb2fbcedb17da6df768468d3

(3) SB600 SMBus Device ID(this issue)
Comment 8 Prarit Bhargava 2007-07-05 10:05:21 EDT
(In reply to comment #7)
> I installed the latest kernel(2.6.9-55.16.EL) and find it boots well
> on my board without the error above.
> 
> And I also checked the source of this kernel version, find the following
> SB600 patches have NOT been included, you may check it:
> (1) IDE has only one channel:
> http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-
> 2.6.git;a=commit;h=b25168dfdc162b4198fa6395cd191a20dddc6d34
> 

BZ #?  

> (2) IDE HDD may not work if using a 40-pin PATA cable
> http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-
> 2.6.git;a=commit;h=e5c073ff24604d4dbb2fbcedb17da6df768468d3
> 

This has been rejected several times and will not be including in RHEL.
Comment 9 Prarit Bhargava 2007-07-05 10:09:46 EDT
(In reply to comment #8)
> (In reply to comment #7)
> > I installed the latest kernel(2.6.9-55.16.EL) and find it boots well
> > on my board without the error above.
> > 
> > And I also checked the source of this kernel version, find the following
> > SB600 patches have NOT been included, you may check it:
> > (1) IDE has only one channel:
> > http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-
> > 2.6.git;a=commit;h=b25168dfdc162b4198fa6395cd191a20dddc6d34
> > 
> 
> BZ #?  
> 

226950 -- was assigned to peterm, but is now assigned to me.

P.
Comment 10 Prarit Bhargava 2007-07-05 11:07:12 EDT
Created attachment 158598 [details]
RHEL4.6: fix for this issue
Comment 11 Jason Baron 2007-07-27 12:00:10 EDT
committed in stream U6 build 55.24. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/
Comment 13 Don Domingo 2007-08-23 21:25:22 EDT
added to RHEL4.6 release notes under "Kernel-Related Updates":

<quote>
AMD and ATI SB600 SMBus Device IDs added to kernel source
</quote>

please advise if any revisions are necessary. thanks!

Comment 14 Shane Huang 2007-08-23 21:44:04 EDT
There is another SMBus new patch, which support SB600/SB700/SB800 with the same
device ID. please add this patch into RHEL4 kernel source. Bugzilla ID: 252287.

This new SMBus patch will be added into RHEL5.2 instead of RHEL5.1,
And I wonder whether it will applied into RHEL4.6 or RHEL4.7 ?

Thanks.
Comment 15 John Poelstra 2007-08-29 13:58:28 EDT
A fix for this issue should have been included in the packages contained in the
RHEL4.6 Beta released on RHN (also available at partners.redhat.com).  

Requested action: Please verify that your issue is fixed to ensure that it is
included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 16 John Poelstra 2007-09-05 18:27:31 EDT
A fix for this issue should have been included in the packages contained in 
the RHEL4.6-Snapshot1 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed to ensure that it is 
included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed, 
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent 
symptoms of the problem you are having and change the status of the bug to 
FAILS_QA.

If you cannot access bugzilla, please reply with a message about your test 
results to Issue Tracker.  If you need assistance accessing 
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 18 errata-xmlrpc 2007-11-15 11:29:51 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0791.html

Note You need to log in before you can comment on or make changes to this bug.