Bug 2466 - Clone gets python exception, line 277
Clone gets python exception, line 277
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: netcfg (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-01 13:36 EDT by Bryce Nesbitt
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-07 18:46:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryce Nesbitt 1999-05-01 13:36:52 EDT
I tried to clone ppp0 to "ppp-local" (this failed because of
a dash).  Then I tried to enter name "ppplocal" and got
this exception:

[root@stetson]# control-panel
Red Hat Linux netcfg 2.18
Copyright (C) 1996, 1997 Red Hat Software
Redistributable under the terms of the GNU General Public
License
Exception in Tkinter callback
Traceback (innermost last):
  File
"/var/tmp/python-root/usr/lib/python1.5/lib-tk/Tkinter.py",
line 752, in __call__
    return apply(self.func, args)
  File "/usr/lib/rhs/python/rhentry.py", line 277, in
<lambda>
    self.E.bind('<Return>', lambda x=self:not x.get() or
x.L.destroy())
AttributeError: get


I'd use Linuxconf, but the UI is so... strange.
Comment 1 David Lawrence 1999-07-07 18:46:59 EDT
I could not get this to fail on a standard 6.0 install in our test
lab.

Note You need to log in before you can comment on or make changes to this bug.