This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 246660 - CIFS signing sec= mount options don't work correctly
CIFS signing sec= mount options don't work correctly
Status: CLOSED DUPLICATE of bug 239339
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Layton
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-03 14:09 EDT by Jeff Layton
Modified: 2007-11-16 20:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-10 07:10:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Layton 2007-07-03 14:09:29 EDT
+++ This bug was initially created as a clone of Bug #246595 +++

email from Steve French:

CIFS code was changing the wrong global variable for signing (the old
one, used only by dead, soon to be removed, code in
fs/cifs/connect.c).  Eventually I need to test ntlm, ntlmv2 etc.
override on command line (with or without the "i" integrity checking
option ie ntlmi ... ntlm with signing etc.)

Comments?

-------[snip]------

not being very familiar with this piece of code, I asked a question:

> Looks pretty straightforward, though this is not an area of code I'm
> very familiar with. Does this mean that integrity checking options are
> broken in recent CIFS versions? Were they working before?


Integrity checking is working if the server is configured to require
it (the most common case) - but the client options that would force it
on were broken.  Signing works for NTLM authentication (most common,
and default)

There is a patch to fix signing for the newer NTLMv2 case (posted to
mainling list) that I am testing now.

--------[snip]--------------

not a catastrophic bug, but would be nice to have. Attached is the (so far,
untested by me) patch sent by Steve F.

-- Additional comment from jlayton@redhat.com on 2007-07-03 06:50 EST --
Created an attachment (id=158420)
patch -- fix sign mount option
Comment 1 Jeff Layton 2007-07-10 07:10:56 EDT

*** This bug has been marked as a duplicate of 239339 ***

Note You need to log in before you can comment on or make changes to this bug.