Bug 246663 - Local automounts fail if nfs is not started
Local automounts fail if nfs is not started
Status: CLOSED DUPLICATE of bug 233149
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: autofs (Show other bugs)
5.0
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ian Kent
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-03 14:39 EDT by Mike
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-03 22:01:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike 2007-07-03 14:39:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; InfoPath.1; .NET CLR 3.0.04506.30)

Description of problem:
When attempted to "cd" into automounted directories, they fail to mount if nfs is not started.  This was not the case with RHEL3 and RHEL4.  Note: We are using NIS maps.

[root@myhost /]$ service nfs stop
Shutting down NFS mountd:                                  [  OK  ]
Shutting down NFS daemon:                                  [  OK  ]
Shutting down NFS quotas:                                  [  OK  ]
Shutting down NFS services:                                [  OK  ]
[root@myhost /]$ ypcat -k auto_data | grep gf
gf $HOST:/export/data/&
[root@myhost /]$ cd /home/data/gf
bash: cd: /home/data/gf: No such file or directory
[root@myhost /]$ service nfs start
Starting NFS services:                                     [  OK  ]
Starting NFS quotas:                                       [  OK  ]
Starting NFS daemon:                                       [  OK  ]
Starting NFS mountd:                                       [  OK  ]
[root@myhost /]$ cd /home/data/gf
[root@myhost gf]$


/var/log/debug, when failing to mount (nfs not started):

Jul  3 14:11:53 myhost automount[21757]: attempting to mount entry /home/data/gf
Jul  3 14:11:53 myhost automount[21757]: lookup_name_file_source_instance: file map not found
Jul  3 14:11:53 myhost automount[21757]: lookup_mount: lookup(yp): looking up gf
Jul  3 14:11:53 myhost automount[21757]: lookup_mount: lookup(yp): gf -> $HOST:/export/data/&
Jul  3 14:11:53 myhost automount[21757]: parse_mount: parse(sun): expanded entry: myhost:/export/data/gf
Jul  3 14:11:53 myhost automount[21757]: parse_mount: parse(sun): gathered options:
Jul  3 14:11:53 myhost automount[21757]: parse_mount: parse(sun): dequote("myhost:/export/data/gf") -> myhost:/export/data/gf
Jul  3 14:11:53 myhost automount[21757]: parse_mount: parse(sun): core of entry: options=, loc=myhost:/export/data/gf
Jul  3 14:11:53 myhost automount[21757]: sun_mount: parse(sun): mounting root /home/data, mountpoint gf, what myhost:/export/data/gf, fstype nfs, options (null)
Jul  3 14:11:53 myhost automount[21757]: mount_mount: mount(nfs): root=/home/data name=gf what=myhost:/export/data/gf, fstype=nfs, options=(null)
Jul  3 14:11:53 myhost automount[21757]: mount_mount: mount(nfs): no hosts available
Jul  3 14:11:53 myhost automount[21757]: send_fail: token = 8408
Jul  3 14:11:53 myhost automount[21757]: failed to mount /home/data/gf
Jul  3 14:11:53 myhost automount[21757]: handle_packet: type = 3
Jul  3 14:11:53 myhost automount[21757]: handle_packet_missing_indirect: token 8409, name gf, request pid 19816
Jul  3 14:11:53 myhost automount[21757]: attempting to mount entry /home/data/gf
Jul  3 14:11:53 myhost automount[21757]: lookup_name_file_source_instance: file map not found
Jul  3 14:11:53 myhost automount[21757]: lookup_mount: lookup(yp): looking up gf
Jul  3 14:11:53 myhost automount[21757]: send_fail: token = 8409
Jul  3 14:11:53 myhost automount[21757]: failed to mount /home/data/gf
Jul  3 14:11:53 myhost automount[21757]: handle_packet: type = 3

Version-Release number of selected component (if applicable):
autofs-5.0.1-0.rc2.42

How reproducible:
Always


Steps to Reproduce:
1. Create localhost automount entry in a nis map
2. Stop nfs via the init script if running
3. Try to "cd" into the directory

Actual Results:
The directory is not found.  

bash: cd: /home/data/gf: No such file or directory

Expected Results:
The directory should have mounted.

Additional info:
Comment 1 Ian Kent 2007-07-03 22:01:12 EDT
This is a known problem. 
Comment 2 Ian Kent 2007-07-03 22:01:47 EDT

*** This bug has been marked as a duplicate of 233149 ***

Note You need to log in before you can comment on or make changes to this bug.