Bug 246664 - hostname is set, but cannot be resolved
hostname is set, but cannot be resolved
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
7
All Linux
medium Severity high
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-03 14:47 EDT by Marius Andreiana
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-08 14:10:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Andreiana 2007-07-03 14:47:52 EDT
Description of problem: I have an xDSL connection defined for an ISP, and eth0
set on DHCP. The ISP will supply a 192.168.x.x IP for eth0 and routable for ppp0
interface.
It will also supply a hostname (e.g. dchpp48) which is set by Linux, but which
has no entry in /etc/hosts. Upon login, Gnome complains it can't resolve current
hostname.

cat /etc/sysconfig/network-scripts/ifcfg-ppp0
TYPE=xDSL
DEVICE=ppp0
BOOTPROTO=dialup
USERCTL=yes
IPV6INIT=no
PEERDNS=yes
PIDFILE=/var/run/pppoe-adsl.pid
FIREWALL=NONE
PING=.
PPPOE_TIMEOUT=80
LCP_FAILURE=3
LCP_INTERVAL=20
CLAMPMSS=1412
CONNECT_POLL=6
CONNECT_TIMEOUT=15
PERSIST=no
SYNCHRONOUS=no
DEFROUTE=yes
USER=...
ETH=eth0
PROVIDER=rds
DEMAND=no
ONBOOT=yes

cat /etc/sysconfig/network-scripts/ifcfg-eth0
# Broadcom Corporation NetXtreme BCM5752 Gigabit Ethernet PCI Express
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:18:8B:AF:FE:C6
ONBOOT=yes
TYPE=Ethernet

cat /etc/sysconfig/network
HOSTNAME=localhost
NETWORKING=yes
yesHOSTNAME=localhost.localdomain


Fix: create correct entry in /etc/hosts
Please let me know if other details are needed.
Comment 1 David Cantrell 2007-10-08 14:10:05 EDT
Your /etc/sysconfig/network file is incorrect.  It looks like you were hit with
a bug found in F-7 where 'yes' is written at the beginning of the HOSTNAME=
line.  Remove the 'yes' at the beginning so that file is parsed correctly.

The /etc/hosts file is not modified by dhclient or the ifup/ifdown scripts. 
That file is meant to be edited manually by the admin of the system.

Correct the /etc/sysconfig/network file and you should be fine after that.

Note You need to log in before you can comment on or make changes to this bug.