Bug 246666 - SELinux is preventing /usr/sbin/wpa_supplicant (NetworkManager_t) "execute_no_trans" to /usr/sbin/wpa_supplicant (NetworkManager_exec_t).
SELinux is preventing /usr/sbin/wpa_supplicant (NetworkManager_t) "execute_no...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-03 15:15 EDT by Bill Nottingham
Modified: 2014-03-16 23:07 EDT (History)
1 user (show)

See Also:
Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 10:15:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-07-03 15:15:49 EDT
Description of problem:

SSIA

Version-Release number of selected component (if applicable):

selinux-policy-3.0.1-6.fc8
NetworkManager-0.6.5-7.fc8
Comment 1 Daniel Walsh 2007-07-03 15:25:37 EDT
That rule should be allowed,  can you attach the avc message?
Comment 2 Bill Nottingham 2007-07-03 15:59:16 EDT
type=AVC msg=audit(1183489825.865:86): avc:  denied  { execute_no_trans } for 
pid=3795 comm=
"NetworkManager" name="wpa_supplicant" dev=sda2 ino=5639713
scontext=system_u:system_r:Networ
kManager_t:s0 tcontext=system_u:object_r:NetworkManager_exec_t:s0 tclass=file
Comment 3 Daniel Walsh 2007-07-03 17:09:30 EDT
selinux-policy-3.0.2-1.fc8  policy has this as allowed.

 audit2why < /tmp/t
type=AVC msg=audit(1183489825.865:86): avc:  denied  { execute_no_trans } for
pid=3795 comm="NetworkManager" name="wpa_supplicant" dev=sda2 ino=5639713
scontext=system_u:system_r:NetworkManager_t:s0
tcontext=system_u:object_r:NetworkManager_exec_t:s0 tclass=file
        Was caused by:
                Unknown - would be allowed by active policy
                Possible mismatch between this policy and the one under which
the audit message was generated.
                Possible mismatch between current in-memory boolean settings vs.
permanent ones.


So I guess it is fixed by tonights rawhide, although I don;t believe anything
has changed.
Comment 4 Daniel Walsh 2007-08-22 10:15:23 EDT
Should be fixed in the current release

Note You need to log in before you can comment on or make changes to this bug.