Bug 246677 - svc_run.c: 100% cpu usage
svc_run.c: 100% cpu usage
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libtirpc (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-03 16:44 EDT by Adam Goode
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 0.1.7-7.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-10 02:42:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix 100% cpu (648 bytes, patch)
2007-07-03 16:44 EDT, Adam Goode
no flags Details | Diff

  None (edit)
Description Adam Goode 2007-07-03 16:44:19 EDT
Description of problem:
Calling svc_run appears to eat up 100% of the cpu after 30 seconds of
runtime; this is because the "struct timeval timeout" only sets its value
outside of the execution loop, despite that select() returns the structure
with undefined value.


Version-Release number of selected component (if applicable):
0.1.7-5.fc7

How reproducible:
Every time.

Steps to Reproduce:
Call svc_run() and wait.

  
Actual results:
100% CPU after 30 seconds.

Expected results:
No spike in CPU usage.


Additional info:
http://sourceforge.net/tracker/index.php?func=detail&aid=1740531&group_id=183075&atid=903784
Comment 1 Adam Goode 2007-07-03 16:44:19 EDT
Created attachment 158474 [details]
Patch to fix 100% cpu
Comment 2 Fedora Update System 2007-07-10 02:42:53 EDT
libtirpc-0.1.7-7.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.