Bug 24668 - re: umount -a problem with server installs/upgrades only
re: umount -a problem with server installs/upgrades only
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
Florence Gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-22 21:12 EST by Henri Schlereth
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-24 03:27:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henri Schlereth 2001-01-22 21:12:11 EST
0. Intitially I was going to switch a windows partition from /w95 --> /w98
first I issued a umount -a (standard to dismount all windows partitions and /home didnt matter for the moment)
Before I got any further I had to back out so I did a mount -a followed by a df. None of the dismounted 
partitions showed and not under mount either. 
cat /proc/mounts showed /dev/root being ro now. After a few failures I decided to test this on other machines.

1. A beta1 machine (same effect but only with / being ro and /home being mounted and invisible under df/mount
2. Two beta2 text server installs, one ide, one scsi same as #1.
3. Firewall RH70 production box. same as 1.

4. Secondary DNS production RH70 box. No effect but it only has 2 partitions / and /boot.

Solution to problem:
1. umount -a
mount -n -o remount rw /
mount -t vfat /dev/hda1 /w95
mount -t ext2 /devhdb1 /home
etc.

After issueing these commands the partitions would again show up under df and mount. The only one that 
didnt error out was the one with the two partitions instead of the RH default partitions.

I am as puzzled as anyone else and would like to see if this can be duplicated. I suspect the combination
of the partition setup and umount. 5 different out of six machines worries my logic.
At any rate it is logged even if it proves bogus.
Comment 1 Henri Schlereth 2001-01-23 11:48:35 EST
So far I am only able to duplicate this problem with server installs/upgrades. Workstation or custom file systems will not 
rewrite /dev/root to ro if the file structure doesnt default to RH partition scheme. I am installing a 6.2 box to see how far back I
can duplicate this.
Comment 2 Glen Foster 2001-01-23 12:49:02 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 3 Henri Schlereth 2001-01-23 16:39:36 EST
Under RH6.2 with a server install and the partitions formated as / /usr /var /home /boot the same problem exists. Under the
conditions of a custom or workstation install say with / /boot or / /home umount -a will not change /dev/root to ro. So mount -a
works as designed.

This may warrant updates for previous releases, and I dont really know how far back since I only retained 6.2 and gave out
my older versions to other people.
Comment 4 Henri Schlereth 2001-01-23 16:42:04 EST
I also forgot to mention that /dev/pts  must be remounted as well else the VT logouts will issue a INIT: id "4" respawning to fast
waiting for 5 minutes and lock out all vt's.
Comment 5 Bill Nottingham 2001-01-23 23:26:57 EST
This was discussed on testers-list; it's not a bug.

umount -a unmounts *everything* if possible, which leaves the root
fs read-only.
Comment 6 Henri Schlereth 2001-01-24 03:27:22 EST
Discussed yes, agreed upon no.

1. This feature is not documented in the man pages anywhere. 

2. This feature does not consistently work if it is not a bug. This feature only
works when I accept the FHS hierarchy that RedHat uses with a server install.
I have used that command as defined in the the man pages for years without
having 
root being made read only.

3. If this is the case then why doesnt mount -a reverse what umount -a does?

There is no reason to modify the permissions of partition that is in use. Even
your rc.sysinit
uses mount -n -o remount ro / to change root dev to read only.
Comment 7 Henri Schlereth 2001-01-24 11:26:35 EST
I will admit that this feature is in the source code and that technically it is not a bug but it still only works sporadically.

Note You need to log in before you can comment on or make changes to this bug.