Bug 246687 - gnome-screenshots doens't save a screen with a 2nd user logged on
Summary: gnome-screenshots doens't save a screen with a 2nd user logged on
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-utils   
(Show other bugs)
Version: 7
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-04 00:55 UTC by marlon bastida
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 2.18.1-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-23 18:51:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description marlon bastida 2007-07-04 00:55:23 UTC
Description of problem:
Trying to save a screenshot on gnome-screenshot using 2nd user logged on,
doens't save in any folder.

Version-Release number of selected component (if applicable):


How reproducible:
Log into a 2nd account using fast-user-switch and try to save a screen on
gnome-screenshot.

Steps to Reproduce:
1. Log into a 2nd regular user created with system-config-user
2. Use fast-user-switching and log into the user Desktop that you want to take a
screenshot
3. Try to save into any folder and you will not get success. You have to force
quit on gnome-screenshot.
  
Actual results:
Doesn't save it to any folder.

Expected results:
Save a screenshot into any folder.

Additional info:

Comment 1 Matthias Clasen 2007-07-06 22:29:57 UTC
The problem is that gnome-screenshot leaves behind a /tmp/gnome-screenshot
directory and tries to create a temp file there. That fails if the directory has
the wrong permissions, because it was left behind by a gnome-screenshot in
another session. It seems there is some cleanup logic which fails to work.

Comment 2 Matthias Clasen 2007-07-06 23:10:00 UTC
I guess this change broke it:

http://svn.gnome.org/viewcvs/gnome-utils/trunk/gnome-screenshot/screenshot-save.c?r1=7298&r2=7318

Comment 3 Fedora Update System 2007-07-09 15:45:54 UTC
gnome-utils-2.18.1-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Fedora Update System 2007-07-23 18:50:57 UTC
gnome-utils-2.18.1-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.