Bug 246699 - KDE deps should be in subpackage
Summary: KDE deps should be in subpackage
Status: CLOSED DUPLICATE of bug 244890
Alias: None
Product: Fedora
Classification: Fedora
Component: gnash   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Patrice Dumas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-04 06:18 UTC by Peter Gordon
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-04 19:46:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Moves the libklash glob to the klash subpackage. (666 bytes, patch)
2007-07-04 06:18 UTC, Peter Gordon
no flags Details | Diff

Description Peter Gordon 2007-07-04 06:18:28 UTC
Description of problem:
Installing gnash-plugin pulls in a KDE-ish dependencies: qt, arts, kdelibs,
kde-settings, and kdnssd-avahi. This should only occur if the user decides to
install the KDE plugin for it, as it creates unnecessary dependency bloat for
GNOME or *box users who otherwise have no need for these packages to be installed.

This appears to be due to the inclusion of the libklash.so glob in the %files
listing. Attached is a patch to move it to the klash subpackage.

Version-Release number of selected component (if applicable):
gnash-0.8.0-1.fc8
gnash-plugin-0.8.0-1.fc8

Comment 1 Peter Gordon 2007-07-04 06:18:28 UTC
Created attachment 158497 [details]
Moves the libklash glob to the klash subpackage.

Comment 2 Patrice Dumas 2007-07-04 07:28:34 UTC
This could make sense, however gnash itself links against the 
same kde libs than klash, so I don't think it is worth it.
Otherwise said, did you test that the split you propose 
removes the kde dependency of gnash?

Comment 3 Peter Gordon 2007-07-04 19:46:39 UTC
(In reply to comment #2)
> This could make sense, however gnash itself links against the 
> same kde libs than klash, so I don't think it is worth it.
> Otherwise said, did you test that the split you propose 
> removes the kde dependency of gnash?

Nah; I didn't explicitly test it. I just thought that changing the file list
there would prevent RPM from automagicallyt picking up the KDE deps.

Thanks for your clarification though. Closing as NOTABUG.


Comment 4 Patrice Dumas 2007-07-04 21:01:50 UTC
I reclose it as a duplicate of a similar bug.

*** This bug has been marked as a duplicate of 244890 ***


Note You need to log in before you can comment on or make changes to this bug.